關於strlwr,strupr等函式在此作用域中尚未宣告的問題
簡單題中遇到的問題!~~
1423: String Task
Time Limit: 1 Sec Memory Limit: 128 MB
[Submit][Status][Web Board]
Description
Petya started to attend programming lessons. On the first lesson his task was to write a simple program. The program was supposed to do the following: in the given string, consisting if uppercase and lowercase Latin letters, it:
·deletes all the vowels,
·inserts a character “.” before each consonant,
·replaces all uppercase consonants with corresponding lowercase ones.
Vowels are letters “A”, “O”, “Y”, “E”, “U”, “I”, and the rest are consonants. The program’s input is exactly one string, it should return the output as a single string, resulting after the program’s processing the initial string.
Help Petya cope with this easy task.
Input
The first line represents input string of Petya’s program. This string only consists of uppercase and lowercase Latin letters and its length is from 1 to 100, inclusive.
Output
Print the resulting string. It is guaranteed that this string is not empty.
Sample Input
tour
Codeforces
aBAcAba
Sample Output
.t.r
.c.d.f.r.c.s
.b.c.b
HINT
第一份提交出現問題程式碼:
#include <stdio.h>
#include <string.h>
char a[105];
int main()
{
while(~scanf("%s",a))
{
strlwr(a);
for(int i = 0; a[i] != '\0'; i++)
{
if(a[i]!='a'&&a[i]!='e'&&a[i]!='i'&&a[i]!='o'&&a[i]!='u')
printf(".%c",a[i]);
}
printf("\n");
}
return 0;
}
出現這種問題是因為判題系統是搭載在linux上~:
總結:
比賽慎用strlwr與strupr(不要用!!反正大小寫轉換easy)
AC程式碼~:
#include <stdio.h>
#include <string.h>
char a[105];
int main()
{
while(~scanf("%s",a))
{
for(int i = 0; a[i] != '\0'; i++)
{
if(a[i] >= 'A'&&a[i] <= 'Z')
a[i] += 32;
if(a[i]!='a'&&a[i]!='e'&&a[i]!='i'&&a[i]!='o'&&a[i]!='u'&&a[i]!='y')
printf(".%c",a[i]);
}
printf("\n");
}
return 0;
}