PAT甲級1005 Spell It Right
阿新 • • 發佈:2018-12-07
題目描述:
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10
100
).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five
題目大意:
給一串數字,求和,將該數的每個數字用英文打出。
程式碼如下:
#include <iostream>
using namespace std;
int main()
{
string s,s2[]={"zero","one","two","three","four","five","six","seven","eight","nine"};
cin>>s;
int sum=0,k;
for(int i=0;i<s.size ();i++)
sum+=s[i]-'0';
string s3=to_string(sum);
for(int i=0;i<s3.size();i++){
cout<<s2[s3[i]-'0'];
if(i!=s3.size()-1) cout<<" ";
}
return 0;
}
來總結一下:
1)數字的最大範圍為10^100,所以只能用string 類來儲存,求和完之後,將int轉化為string類,然後對應輸出相應的英文字母。