1. 程式人生 > >結構體排序問題

結構體排序問題

Problem Description

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.

Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

Sample Input

3 6 4

2 2.5 5 1 3 4

5 1 3.5 2 2 2

1 1 1 1 1 10

3 3 2

1 2 3

2 3 1

3 1 2

Sample Output

6 5 3 1

2 1

題目描述:題意的大概意思就是不同的人為不同的圖案打分,設計者挑選評論比較滿意的幾個作為設計標準,要儘可能滿足更多人的需求。每個圖案都標有序號,按倒序輸出,如果圖案的滿意度相同,倒敘輸出序號小的優先。

思路:因為有多個人對不同的圖案打分,所以我們可以利用結構體儲每個物品的序號以及所有人對它評分的和,用它的評分排序然後按要求輸出序號就可以了。

程式碼:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

struct pai
{
    int num,sum;
}a[100000];
bool cmp(pai a,pai b)
{
    if(a.num>b.num)
        return true;
    else
        return false;
}
bool cmpe(pai a,pai b)
{
    if(a.sum>=b.sum)
        return true;
    else
        return false;
}

int main()
{
    int n,m,k;
    double s;
    while(scanf("%d %d %d",&n,&m,&k)!=EOF)
    {
        for(int i=0;i<m;i++)
        {
            a[i].num=0;
            a[i].sum=i+1;
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                scanf("%lf",&s);
                a[j].num+=s;
            }
        }
        sort(a,a+m,cmp);
        sort(a,a+k,cmpe);
        for(int j=0;j<k-1;j++)
        {
            printf("%d ",a[j].sum);
        }
        printf("%d\n",a[k-1].sum);
    }
    return 0;
}