1. 程式人生 > >1134 Vertex Cover (25 分)(cj)

1134 Vertex Cover (25 分)(cj)

1134 Vertex Cover (25 分)

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes

 if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <stdio.h>
#include <string>
#include <set>
using namespace std;
int vertice[10005];
int edge[10005][2];
int main() {
	int n, m;
	cin >> n >> m;
	int x, y;
	for (int i = 0; i < m; ++i) {
		cin >> edge[i][0] >> edge[i][1];
	}
	int k, num;
	cin >> k;
	set<int> ss;
	while (k--) {
		ss.clear();
		cin >> num;
		while (num--) {
			cin >> x;
			ss.insert(x);
		}
		bool f = 1;
		for (int i = 0; i < m; ++i) {
			if (ss.find(edge[i][0]) == ss.end() && ss.find(edge[i][1]) == ss.end()) {
				f = 0; break;
			}
		}
		if (f) cout << "Yes" << endl;
		else cout << "No" << endl;
	}
	system("pause");
	return 0;
}