程式設計基礎16 tips 非二叉樹求權重
1053 Path of Equal Weight (30 分)
Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a given non-leaf node, K
is the number of its children, followed by a sequence of two-digit ID
's of its children. For the sake of simplicity, let us fix the root ID to be 00
.
Output Specification:
For each test case, print all the paths with weight S in non-increasing
Note: sequence {A1,A2,⋯,An} is said to be greater than sequence {B1,B2,⋯,Bm} if there exists 1≤k<min{n,m} such that Ai=Bi for i=1,⋯,k, and Ak+1>Bk+1.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
一,關於結果的表示和儲存問題:
我的方法:用二維的vector儲存每一條路徑,但是二維vector輸出略顯麻煩,易出錯。
簡便方法:用一維陣列儲存每一條路徑,達到條件之後就在子函式DFS()中輸出,但是關於有的路徑長度不一樣怎麼辦呢?解決方法就是在子函式DFS()中加入形參numNode,記錄當前路徑中的結點數目即可,即是這一個路徑比上一個路徑結點數目少,但是隻遍歷到numNode,就不管後面的了。
二,關於每一個結點的孩子結點如何由大到小排序的問題
我的方法:
這是不對的,主要在於sort裡面的不能是與原陣列(這裡即為child這個vector)無關的東西,在這個vector裡面比,sort就必須是這個vector.
int num = 0;
for (int j = 0; j < num; j++) {
scanf("%d", &child);
arr[num++] = child;
node[root].child.push_back(child);
}
sort(arr,arr+num cmp);
bool cmp(int a, int b) {
return node[a].weight > node[b].weight;
}
正確方法:
注意註釋中的方法是錯的,begin()和end()是vector比較指定專用方法。
for (int j = 0; j < num; j++) {
scanf("%d", &child);
node[root].child.push_back(child);
}
sort(node[root].child.begin(), node[root].child.end(), cmp);
//sort(node[root].child, node[root].child + num, cmp);
bool cmp(int a, int b) {
return node[a].weight > node[b].weight;
}
三,正確程式碼
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
//到7:50 到8:25
const int maxn = 110;
int N = 0;
int M = 0;
int S = 0;
int path[maxn] = { 0 };
struct Node {
int weight;
vector<int> child;
}node[maxn];
bool cmp(int a, int b) {
return node[a].weight > node[b].weight;
}
void DFS(int root, int numNode, int nowWeight) {
if (node[root].child.size() == 0) {
if (nowWeight == S) {
for (int i = 0; i < numNode; i++) {
printf("%d", node[path[i]].weight);
if (i != numNode - 1) {
printf(" ");
}
}
printf("\n");
}
return;
}
if (nowWeight < S) {
for (int i = 0; i < node[root].child.size();i++) {
path[numNode] = node[root].child[i];
DFS(node[root].child[i], numNode + 1, nowWeight + node[node[root].child[i]].weight);
}
}
}
int main() {
int weight = 0;
int root = 0;
int num = 0;
int child = 0;
scanf("%d %d %d", &N, &M, &S);
for (int i = 0; i < N; i++) {
scanf("%d", &weight);
node[i].weight = weight;
}
for (int i = 0; i < M; i++) {
scanf("%d", &root);
scanf("%d", &num);
for (int j = 0; j < num; j++) {
scanf("%d", &child);
node[root].child.push_back(child);
}
sort(node[root].child.begin(), node[root].child.end(), cmp);//sort(node[root].child, node[root].child + num, cmp);
}
path[0] = 0;
DFS(0, 1, node[0].weight);
return 0;
}