1. 程式人生 > >第五次測試 大小寫轉換

第五次測試 大小寫轉換

Eddy usually writes articles ,but he likes mixing the English letter uses, for example “computer science” is written frequently “coMpUtEr scIeNce” by him, this mistakes lets Eddy’s English teacher be extremely discontentment.Now please you to write a procedure to be able in the Bob article English letter to turn completely the small letter.


Input
The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation
composition, the writing length does not surpass 1000 characters.
Output
For each test case, you should output an only line, after namely the result of transforms the lowercase letter.
Sample Input

weLcOmE tO HDOj Acm 2005!
Sample Output
welcome to hdoj acm 2005!
嗯,看起來很傻逼對吧,純英文題,作為一個英語從來不及格的愛國有志青年在看到這種題時,心裡滿滿的草泥馬,但是沒辦法,稍微上檔次的比賽,都是英文題。看不懂就只能找翻譯了。

艾迪經常寫文章,但是他喜歡混用英語字母,例如“電腦科學”經常是他寫的“電腦科學”,這個錯誤讓艾迪的英語老師非常不滿。現在請你寫一篇程式能在鮑勃的文章中把英文字母完全變成小寫字母。
**輸入”
輸入包含幾個測試用例。每行由一個測試用例組成,表達渦流寫在一篇文章中,由字母、空格、數字以及各種標點組成,寫作長度不超過1000個字元
**輸出
*對於每個測試用例,您應該只輸出一行,即轉換小寫字母后的結果。

以上是我用有道翻譯的結果,不可能詞意通達,但大體明白題目的要求就行,示例的話應該都能看懂。
話不多說,直接貼程式碼

#include<stdio.h>
int main ()
{
	char a[1000];
	int i;
	while(gets(a)!=NULL)
	{ 
		int t;
		t=sizeof(a)/sizeof(a[0]);
		for(i=0;i<t;i++)
		{
			if(a[i]<='Z'&&a[i]>='A')
			{
				a[i]=a[i]+32;
			}
		}
		printf("%s\n",a);
	}
	return 0;
}

很簡單的題,算是這次測試的簽到題吧,也沒什麼好說的,只要注意一下空格就好了,用gets寫入字串以識別空格,注意一下控制多組輸入多組輸出的是NULL而不是EOF。