【題解】hdu2689 Sort it 樹狀陣列
阿新 • • 發佈:2018-12-10
Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need. For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
Output
For each case, output the minimum times need to sort it in ascending order on a single line.
Sample Input
3 1 2 3 4 4 3 2 1
Sample Output
0 6
樹狀陣列求逆序對裸題……5分鐘以內寫完,還算比較熟
#include<cstdio>
#include<cstring>
const int N=1e3+10;
int n,sum[N<<1];
void add(int x){for(;x<=n;x+=x&-x)sum[x]++;}
int query(int x)
{
int ret=0;
for(;x;x-=x&-x)ret+=sum[x];
return ret;
}
int main()
{
//freopen("in.txt","r",stdin);
while(~scanf("%d",&n))
{
int ans=0;
memset(sum,0,sizeof(sum));
for(int i=1;i<=n;i++)
{
int x;
scanf("%d",&x);
ans+=query(n)-query(x-1);
add(x);
}
printf("%d\n",ans);
}
return 0;
}
總結
巨水