1. 程式人生 > >【ZCMU3037】Block Towers(貪心)

【ZCMU3037】Block Towers(貪心)

題目連結

3037: Block Towers

Time Limit: 2 Sec  Memory Limit: 256 MB Submit: 48  Solved: 20 [Submit][Status][Web Board]

Description

C. Block Towers

Students in a class are making towers of blocks. Each student makes a (non-zero) tower by stacking pieces lengthwise on top of each other. n of the students use pieces made of two blocks and m

of the students use pieces made of three blocks.

The students don’t want to use too many blocks, but they also want to be unique, so no two students’ towers may contain the same number of blocks. Find the minimum height necessary for the tallest of the students' towers.

Input

 The first line of the input contains two space-separated integers n and m (0≤n,m≤1000000, n+m>0)− the number of students using two-block pieces and the number of students using three-block pieces, respectively.

Output

 Print a single integer, denoting the minimum possible height of the tallest tower.

Sample Input

1 3

Sample Output

9

HINT

 In the first case, the student using two-block pieces can make a tower of height 4, and the students using three-block pieces can make towers of height 3, 6, and 9 blocks. The tallest tower has a height of 9 blocks.

【題意】

有n個人用2層的磚塊建塔,有m個人用3層的磚塊建塔,每個人的塔的高度要求不同,求最高的塔的最小高度。

【解題思路】

被最高的塔的最小高度困擾了好久……

因為每個人建塔的高度要求不同,可以先考慮如果可以相同的話,可以建的最高的塔的最小高度肯定是max(2*n,3*m)。

比如n=4,m=3時n個人可建的塔為2 4 6 8  m個人可建的塔為3 6 9,但最小高度不是9,因為高度為6的塔重複了(事實上之後所有6的倍數的塔高都會重複),所以只需比較8和9的大小,因為8比9小,為了滿足題意,就將8+2=10,最後再求個max(n,m)即可。

【程式碼】

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        n*=2;
        m*=3;
        int x=6;
        while(x<=min(n,m))
        {
            if(n<m)n+=2;
            else m+=3;
            x+=6;
        }
        printf("%d\n",max(n,m));
    }
    return 0;
}