1. 程式人生 > >【題解】poj2279Mr. Young's Picture Permutations 楊氏矩陣

【題解】poj2279Mr. Young's Picture Permutations 楊氏矩陣

題目連結

Description

Mr. Young wishes to take a picture of his class. The students will stand in rows with each row no longer than the row behind it and the left ends of the rows aligned. For instance, 12 students could be arranged in rows (from back to front) of 5, 3, 3 and 1 students. X X X X X

X X X

X X X

X

In addition, Mr. Young wants the students in each row arranged so that heights decrease from left to right. Also, student heights should decrease from the back to the front. Thinking about it, Mr. Young sees that for the 12-student example, there are at least two ways to arrange the students (with 1 as the tallest etc.): 1 2 3 4 5 1 5 8 11 12

6 7 8 2 6 9

9 10 11 3 7 10

12 4

Mr. Young wonders how many different arrangements of the students there might be for a given arrangement of rows. He tries counting by hand starting with rows of 3, 2 and 1 and counts 16 arrangements: 123 123 124 124 125 125 126 126 134 134 135 135 136 136 145 146

45 46 35 36 34 36 34 35 25 26 24 26 24 25 26 25

6 5 6 5 6 4 5 4 6 5 6 4 5 4 3 3

Mr. Young sees that counting by hand is not going to be very effective for any reasonable number of students so he asks you to help out by writing a computer program to determine the number of different arrangements of students for a given set of rows.

Input

The input for each problem instance will consist of two lines. The first line gives the number of rows, k, as a decimal integer. The second line contains the lengths of the rows from back to front (n1, n2,…, nk) as decimal integers separated by a single space. The problem set ends with a line with a row count of 0. There will never be more than 5 rows and the total number of students, N, (sum of the row lengths) will be at most 30.

Output

The output for each problem instance shall be the number of arrangements of the N students into the given rows so that the heights decrease along each row from left to right and along each column from back to front as a decimal integer. (Assume all heights are distinct.) The result of each problem instance should be on a separate line. The input data will be chosen so that the result will always fit in an unsigned 32 bit integer.

Sample Input

1 30 5 1 1 1 1 1 3 3 2 1 4 5 3 3 1 5 6 5 4 3 2 2 15 15 0

Sample Output

1 1 16 4158 141892608 9694845

書上提到一個叫楊氏矩陣的東東,於是去學習了大佬題解,核心摘抄如下: 題目中的排列方式稱為楊氏矩陣,它有一個公式來計算排列的數目,該數目設為F(n)函式的話,那麼有遞推式: F(1) = 1 F(2) = 2 F(n) = F(n-1) + (n-1) * F(n-2) ,( n > 2 )

如果是規定了形狀的楊氏矩陣,那麼就有一個鉤子公式來計算排列的數目 對於n個元素,公式為: ans = n! * (每個格子【下方】和右邊格子的數量+1 的乘積) 這篇文章講楊氏矩陣也講的很好。

#include<cstdio>
#include<cstring>
typedef long long ll;
int n,sum[2010],row[2010],cnt;
ll ans;
ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
int main()
{
	//freopen("in.txt","r",stdin);
    while(scanf("%d",&n)&&n)
    {
    	memset(sum,0,sizeof(sum));cnt=0;
    	for(int i=1;i<=n;i++)scanf("%d",&row[i]);
	    for(int i=1;i<=n;i++)
	        for(int j=1;j<=row[i];j++)
	        {
	        	cnt++;//第cnt個元素 
	        	for(int k=i+1;k<=n;k++)
	        	    if(row[k]>=j)sum[cnt]++;
	        	    else break;
	        	sum[cnt]+=row[i]-j+1;//加右邊剩下的元素 
			}
		ll a=1,b=1;
		for(int i=1;i<=cnt;i++)
		{
			a*=i;b*=sum[i];
			ll d=gcd(a,b);
			a/=d,b/=d;
		}
		printf("%lld\n",a/b);
	}
	return 0;
}

總結

又是些我不會的騷東西(我不會不是很正常嗎