1. 程式人生 > >Parity game POJ - 1733(並查集 + 離散化)

Parity game POJ - 1733(並查集 + 離散化)

 

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

典型的一個帶權並查集,需要注意的是資料範圍有點大,應該是到了1e8,陣列是開不了的,需要用到一波離散化,壓縮一下資料範圍。至於離散化的詳細過程,之前的一篇部落格有詳細寫過,是關於線段樹和離散化,離散化傳送門

離散化的時候注意 保留原來資料的連續關係!!

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

const int maxn = 5050;
int len, n;
int pre[maxn << 3];
int sum[maxn << 3];
int xx[maxn << 3], yy[maxn << 3];

struct lr{
	int a, b;
	int num;
}input[maxn];

int finds(int x)
{
	if(pre[x] == x)
		return x;
	int t = finds(pre[x]);
	sum[x] = sum[x] ^ sum[pre[x]];
	return pre[x] = t;
}

int Bin(int l, int r, int x)
{
	while(l < r)
	{
		int mid = (l + r) / 2;
		if(xx[mid] == x)
			return mid + 1;
		if(xx[mid] > x)
		{
			r = mid - 1;
		}
		else
		{
			l = mid + 1;
		}
	}
	return l + 1;
}

int main()
{
	//freopen("in.txt", "r", stdin);
	cin >> len;
	cin >> n;
	string st;
	memset(sum, 0, sizeof(sum));
	//lisanhua
	int cnt = 0;
	for(int i = 1; i <= n; ++ i)
	{
		scanf("%d%d", &input[i].a, &input[i].b);
		yy[cnt++] = input[i].a, yy[cnt++] = input[i].b;
		cin >> st;
		if(st == "even")
			input[i].num = 0;
		else
			input[i].num = 1;
	}
	////
	sort(yy, yy + cnt);
	int res = 0;
	xx[res++] = yy[0];
	for(int i = 1; i < cnt; ++ i)
	{
		if(yy[i] != yy[i - 1])
			xx[res++] = yy[i];
	}
	int tmp = res;
	for(int i = 0; i < res - 1; ++ i)
	{
		if(xx[i + 1] - 1 > xx[i])
		{
			xx[tmp++] = xx[i] + 1;
		}
	}
	sort(xx, xx + tmp);
	////
	for(int i = 0; i <= tmp; ++ i)
	{
		pre[i] = i;
	}
	for(int i = 1; i <= n; ++ i)
	{
		int l = Bin(0, tmp - 1, input[i].a);
		int r = Bin(0, tmp - 1, input[i].b);
		//cout << l << ' ' << r << endl;
		int temp = input[i].num;
		l --;
		int fa = finds(l);
		int fb = finds(r);
		if(fa == fb)
		{
			//cout << l + 1 << ' ' << r << ' ' << (sum[r] ^ sum[l]) << endl;
			if(sum[r] ^ sum[l] != temp)
			{
				cout << i - 1 << endl;
				return 0;
			}
		}
		else
		{
			if(fa < fb)
			{
				pre[fb] = fa;
				sum[fb] = sum[r] ^ temp ^ sum[l];
			}
			else
			{
				pre[fa] = fb;
				sum[fa] = sum[r] ^ temp ^ sum[l];
			}
		}
	}
	cout << n << endl;
	return 0;
}