1. 程式人生 > >【Actoder Arc 066】C

【Actoder Arc 066】C

C - Lining Up

Time limit : 2sec / Memory limit : 256MB

Score : 300 points

Problem Statement

There are N people, conveniently numbered 1 through N. They were standing in a row yesterday, but now they are unsure of the order in which they were standing. However, each person remembered the following fact: the absolute difference of the number of the people who were standing to the left of that person, and the number of the people who were standing to the right of that person. According to their reports, the difference above for person i

is Ai.

Based on these reports, find the number of the possible orders in which they were standing. Since it can be extremely large, print the answer modulo 109+7. Note that the reports may be incorrect and thus there may be no consistent order. In such a case, print 0.

Constraints

  • 1≦N≦105
  • 0≦AiN−1

Input

The input is given from Standard Input in the following format:

N
A1 A2 … AN

Output

Print the number of the possible orders in which they were standing, modulo 109+7.

Sample Input 1

Copy

5
2 4 4 0 2

Sample Output 1

Copy

4

There are four possible orders, as follows:

  • 2,1,4,5,3
  • 2,5,4,1,3
  • 3,1,4,5,2
  • 3,5,4,1,2

Sample Input 2

Copy

7
6 4 0 2 4 0 2

Sample Output 2

Copy

0

Any order would be inconsistent with the reports, thus the answer is 0.

Sample Input 3

Copy

8
7 5 1 1 7 3 5 3

Sample Output 3

Copy

16

解析:

       易知合法情況中每種絕對差出現兩次(奇數要特殊考慮一下中間那個數)。

       由於沒對數有兩種情況,所以總法案數量為2^{n/2}

程式碼:  

#include <bits/stdc++.h>
#define int long long
using namespace std;

const int mod=1e9+7;
const int Max=100005;
int n,m,s;
int sum[Max];

inline int ksm(int a,int b)
{
	int ans=1;
	while(b)
	{
	  if(b&1) ans=(ans*a)%mod;
	  b>>=1;
	  a=(a*a)%mod;
	}
	return ans;
}

signed main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++) scanf("%d",&m),sum[m]++;
	for(int i=0;i<n;i++) if(sum[i]>=3) {cout<<"0";return 0;}
	if((n&1&&sum[0]!=1)||(!(n%2)&&sum[0])) {cout<<"0";return 0;}
	cout<<ksm(2,n/2);
	return 0;
}