1. 程式人生 > >Wrestling Match HDU

Wrestling Match HDU

Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into "good player" and "bad player".

Input

Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known "good players" and the number of known "bad players".In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a "good player" number.The last line contains Y different numbers.Each number represents a known "bad player" number.Data guarantees there will not be a player number is a good player and also a bad player.

Output

If all the people can be divided into "good players" and "bad players”, output "YES", otherwise output "NO".

Sample Input

5 4 0 0
1 3
1 4
3 5
4 5
5 4 1 0
1 3
1 4
3 5
4 5
2

Sample Output

NO
YES

歸納總結

圖:  特別注意:

1.孤立點

2.好多聯通塊

3.環(矛盾確定的結構)

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;

#define rep(i,a,b) for(int i=a;i<b;++i)
#define per(i,a,b) for(int i=b-1;i>=a;--i)

const int N=1010;
vector<int> edge[N];

int deg[N],col[N],vis[N];

int main()
{
    int n,m,x,y;
    while(scanf("%d %d %d %d",&n,&m,&x,&y)==4) {

        rep(i,0,n+1) {
            edge[i].clear();
            deg[i]=vis[i]=0;
            col[i]=-1;
        }

        rep(i,0,m) {
            int u,v;
            scanf("%d %d",&u,&v);
            edge[u].push_back(v);
            edge[v].push_back(u);
            deg[u]++;
            deg[v]++;
        }

        int t;
        rep(i,0,x) {
            scanf("%d",&t);
            col[t]=1;
        }
        rep(i,0,y) {
            scanf("%d",&t);
            col[t]=0;
        }


        int ok=1;
        rep(i,1,n+1) {
            if(col[i]==-1&&!deg[i]) {
                ok=0;
                break;
            }
        }
        if(!ok) {
            printf("NO\n");
            continue;
        }

        queue<int> q;
        rep(i,1,n+1) {
            if(col[i]!=-1) {
                q.push(i);
            }
        }

        while(!q.empty()) {
            int u=q.front();
            q.pop();
            int sz=edge[u].size();
            rep(i,0,sz) {
                int v=edge[u][i];
                if(col[v]!=-1) {
                    if(col[v]^col[u]==0) {
                        //printf("u:%d v:%d\n",u,v);
                        ok=0;
                        break;
                    }
                } else {
                    col[v]=col[u]^1;
                    q.push(v);
                }
            }
            if(!ok)break;
        }

        //printf("***\n");
        rep(i,1,n+1) {
            if(col[i]!=-1)continue;
            col[i]=1;
            q.push(i);
            while(!q.empty()) {
                int u=q.front();
                q.pop();
                int sz=edge[u].size();
                rep(i,0,sz) {
                    int v=edge[u][i];
                    if(col[v]!=-1) {
                        if(col[v]^col[u]==0) {
                            //printf("u:%d v:%d\n",u,v);
                            ok=0;
                            break;
                        }
                    } else {
                        col[v]=col[u]^1;
                        q.push(v);
                    }
                }
                if(!ok)break;
            }
            if(!ok)break;
        }

        if(ok)printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}