HDU 1686 Oulipo(KMP)
Description:
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input:
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W). One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output:
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input:
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
Sample Output:
1 3 0
題目連結
求模式串在主串中的出現次數,KMP演算法模板題。
AC程式碼:
#include <iostream>
#include <vector>
#include <string>
using namespace std;
void KMPPre(string Pattern, vector<int> &Next) {
int i = 0, j = -1;
Next[0] = -1;
int Len = int(Pattern.length());
while (i != Len) {
if (j == -1 || Pattern[i] == Pattern[j]) {
Next[++i] = ++j;
}
else {
j = Next[j];
}
}
}
void PreKMP(string Pattern, vector<int> &Next) {
int i, j;
i = 0;
j = Next[0] = -1;
int Len = int(Pattern.length());
while (i < Len) {
while (j != -1 && Pattern[i] != Pattern[j]) {
j = Next[j];
}
if (Pattern[++i] == Pattern[++j]) {
Next[i] = Next[j];
}
else {
Next[i] = j;
}
}
}
int KMPCount(string Pattern, string Main, vector<int> &Next) {
//PreKMP(Pattern, Next);
KMPPre(Pattern, Next);
int PatternLen = int(Pattern.length()), MainLen = int(Main.length());
int i = 0, j = 0;
int Ans = 0;
while (i < MainLen) {
while (j != -1 && Main[i] != Pattern[j]) {
j = Next[j];
}
i++; j++;
if (j >= PatternLen) {
Ans++;
j = Next[j];
}
}
return Ans;
}
int main(int argc, char *argv[]) {
int T;
cin >> T;
for (int Case = 1; Case <= T; ++Case) {
string Main, Pattern;
cin >> Pattern >> Main;
vector<int> Next(int(Pattern.length()) + 1, 0);
cout << KMPCount(Pattern, Main, Next) << endl;
}
return 0;
}