1028 List Sorting (25 分)字串排序
題目
Excel can sort records according to any column. Now you are supposed to imitate this function.
Input Specification:
Each input file contains one test case. For each case, the first line contains two integers N (≤
) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).
Output Specification:
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.
Sample Input 1:
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2:
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3:
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
解題思路
使用algorithm::sort進行排序即可,可以用函式指標方便呼叫對應的排序函式。注意: 不要使用cin,否則最後一個測試點會超時。
/*
** @Brief:No.1028 of PAT advanced level.
** @Author:Jason.Lee
** @Date:2018-12-04
** @status: Accepted!
*/
#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
using namespace std;
struct students{
char id[10];
char name[10];
int grade;
};
bool cmp1(students a,students b){
return strcmp(a.id,b.id)<=0;
}
bool cmp2(students a,students b){
return strcmp(a.name,b.name)<=0;
}
bool cmp3(students a,students b){
return a.grade<=b.grade;
}
int main(){
int N,C;
while(cin>>N>>C){
vector<students> records;
students input;
for(int i=0;i<N;i++){
scanf("%s %s %d",input.id,input.name,&input.grade);
records.push_back(input);
}
bool (*cmp[])(students,students)= {cmp1,cmp2,cmp3};
sort(records.begin(),records.end(),cmp[C-1]);
for(auto elem:records){
cout<<elem.id<<" "<<elem.name<<" "<<elem.grade<<endl;
}
}
return 0;
}
cin和cout比想象中的耗時,如果使用cin和cout,會超時,如果使用scanf+cout,大約300ms,如果使用printf+scanf,只需要100ms。