1. 程式人生 > >PAT (Advanced Level) Practice 1037

PAT (Advanced Level) Practice 1037

1037 Magic Coupon (25 分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

 分析:可以用二重迴圈求最大值,但數量級過大,這樣寫會超時。此處用貪心思想,將優惠券與物價從小到大排列,從頭開始將所有對應的負數相乘,再從尾開始將所有對應的正數相乘,即可得到最大的絕對值的和。

 程式碼:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int main() {
	int ans = 0;
	int Nc, Np;
	vector<int> C, P;
	cin >> Nc;
	for (int i = 0; i < Nc; i++) {
		int temp;
		//cin >> temp;
		scanf("%d", &temp);
		C.push_back(temp);
	}
	cin >> Np;
	for (int i = 0; i < Np; i++) {
		int temp;
		//cin >> temp;
		scanf("%d", &temp);
		P.push_back(temp);
	}
	sort(C.begin(), C.end());
	sort(P.begin(), P.end());
	int i = 0, j = 0;
	while (i < Nc && j < Np && C[i] < 0 && P[j] < 0) {
		ans += C[i] * P[j];
		i++;
		j++;
	}
	i = Nc - 1, j = Np - 1;
	while (i >= 0 && j >= 0 && C[i] > 0 && P[j] > 0) {
		ans += C[i] * P[j];
		i--;
		j--;
	}
	cout << ans << endl;
	return 0;
}