(甲)1003 Emergency
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.
Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4
key:
最短路問題,完全參考演算法筆記寫的。。
#include <iostream>
#include <algorithm>
#include <cstring>
#define MAXV 1000 //最大頂點數
#define INF 0x3fffffff //無窮大
using namespace std;
int n,G[MAXV][MAXV],num[MAXV]= {0}; //n為頂點數,G為鄰接矩陣,num記錄最短路徑數
int d[MAXV],weight[MAXV],w[MAXV]= {0}; //d記錄最短距離,weight記錄點的權重,w記錄最大點權之和
bool vis[MAXV]= {false}; //開始時候所有點未被訪問
void Dijkstra(int s) //s為起點
{
fill(d,d+MAXV,INF);
d[s]=0;
num[s]=1;
w[s]=weight[s];
for(int i=0; i<n; i++)
{
int u=-1,MIN=INF;
for(int j=0; j<n; j++) //找到未訪問頂點中d最小的
{
if(vis[j]==false&&d[j]<MIN)
{
u=j;
MIN=d[j];
}
}
if(u==-1) return; //剩下的頂點與起點均不連通
vis[u]=true; //標記為已經訪問
for(int v=0; v<n; v++)
{
if(vis[v]==false&&G[u][v]!=INF&&d[u]+G[u][v]<d[v]) //頂點v未被訪問且u能到達v且u作為中介點可以使d更優
{
d[v]=d[u]+G[u][v];
w[v]=w[u]+weight[v];
num[v]=num[u];
}
else if(vis[v]==false&&G[u][v]!=INF&&d[u]+G[u][v]==d[v]) //長度相等時
{
num[v]+=num[u];
if(w[u]+weight[v]>w[v]) //優化最大點權
w[v]=w[u]+weight[v];
}
}
}
}
int main()
{
int x,start,end,t,u,v;
cin>>n>>x>>start>>end;
fill(G[0],G[0]+MAXV*MAXV,INF);
for(int i=0; i<n; i++)
{
cin>>weight[i];
}
while(x--)
{
cin>>u>>v>>t;
G[u][v]=t;
G[v][u]=t;
}
Dijkstra(start);
cout<<num[end]<<" "<<w[end];
return 0;
}