1. 程式人生 > >1017 Queueing at [email protected]

1017 Queueing at [email protected]

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS

 - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

 題目分析:

1.將時間換算成秒,邊界分別是8*3600 和 17*3600。

2. 只要顧客到達時間在17點之前,就能接受服務,隊伍排到17點之後也沒關係。

3. 不要忘記加上8點之前到達的顧客的等待時間,他們在排隊之前也要等待銀行開門。

4.到達時間晚於17點的直接略去。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <vector>
#include <set>
#include <stack>
#include <iomanip>

using namespace std;

struct Node{
	int a_time; //到達時間
	int p; //受服務時間
}cus[10003]; //顧客

int lines[103]; //服務視窗,記錄的是該視窗服務完最近一個顧客時的時間

bool cmp(const Node &a,const Node &b){
	return a.a_time < b.a_time;
} 

int main(){
	int n,k;
	scanf("%d%d",&n,&k);

	int HH,MM,SS,P;
	for(int i=0;i<n;++i){
		scanf("%d:%d:%d%d",&HH,&MM,&SS,&P);
		// int a_time = ;
		cus[i].a_time = HH*3600 + MM*60 + SS;
		cus[i].p = P*60;
	}
	sort(cus,cus+n,cmp);

	int total = 0;
	int num = 0;
	memset(lines,-1,sizeof(lines)); //值為-1時代表該視窗還沒有顧客

	for(int i=0;i<n;++i){
		if(cus[i].a_time > 17*3600) break;
		sort(lines,lines+k); //需要每次sort,找到最早服務完顧客的視窗
		
		if(cus[i].a_time <= 8*3600){
			if(lines[0] == -1){
				total += 8*3600-cus[i].a_time;
				lines[0] = 8*3600 + cus[i].p;
			}
			else{
				total += lines[0]-8*3600;
				lines[0] += cus[i].p;
				// continue;
			}
		}
		else{
			if(lines[0] <= cus[i].a_time){
				lines[0] = cus[i].a_time + cus[i].p;
				// continue;
			}
			else{
				total += lines[0]-cus[i].a_time;
				lines[0] += cus[i].p;
			}
		}
		++num;
	}
	// cout << "total is " << total << endl;
	// cout << "num is " << num << endl;
	if(num == 0) cout << "0.0" << endl;
	else printf("%.1lf\n",(double)total/num/60.0);
	return 0;
}