1. 程式人生 > >Catch That Cow HDU

Catch That Cow HDU

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.  * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute  * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.  If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

題意:

 農夫在n點,牛在k點,找到從n到k的最短時間。

 bfs程式碼:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int n,k;
struct node{
	int x;    //位置
	int step; //時間
};
int vis[200000];  //標記走過的點
queue<struct node> q;
void bfs()
{
	while(!q.empty())q.pop();  //佇列置空
	memset(vis,0,sizeof(vis));
	vis[n]=1;
	struct node nod={n,0}; 
	q.push(nod);
	while(!q.empty())
	{
		struct node newn=q.front();
		q.pop();
		int tx;
		if(newn.x==k)    //如果現在的位置=牛所在的位置就停止迴圈
		{
			printf("%d\n",newn.step);
			break;
		}
		for(int i=0;i<3;i++)
		{
			switch(i){
				case 0:
					tx=newn.x+1;
					break;
				case 1:
					tx=newn.x-1;
					break;
				case 2:
					tx=newn.x*2;
					break;
			}
			if(tx>=0&&tx<=200000&&vis[tx]==0)  //所在的位置符合條件就入隊
			{
				struct node d={tx,newn.step+1};
				q.push(d);
				vis[tx]=1;
			}
		}
	}
	return;
}
int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
	{ 	
	   bfs();
	} 
	return 0;
}