1. 程式人生 > >整數後移(Java程式設計)

整數後移(Java程式設計)

“整數後移問題”(即右移問題)

題目描述 description

有n個整數,使前面各數順序向後移m個位置,最後m個數變成前面m個數,見圖。寫一函式:實現以上功能,在主函式中輸入n個數和輸出調整後的n個數。

輸入 input

輸入資料的個數n n個整數 移動的位置m

輸出 output

移動後的n個數

樣例輸入 sample input

10

樣例輸出 sample output

1 2 3 4 5 6 7 8 9 10

9 10 1 2 3 4 5 6 7 8

源程式示例:

import java.util.Arrays;

import java.util.Scanner;

public class test2{

public static void main(String[] args) {

// TODO Auto-generated method stub

Scanner a=new Scanner(System.in);      

int s=a.nextInt();     

int []arr = new int[s];    //以你所輸入的整數當作這個陣列的終止下標

for(int i=0;i<s;i++)

{

arr[i]=i+1;

}

System.out.print(Arrays.toString(arr));  //輸出這個陣列arr

System.out.print(" ");

System.out.println();

  Scanner b=new Scanner(System.in);

  int mo=b.nextInt();    //

  move(arr,mo);          //再輸入需要後移的位數

   }

public static void  move(int a[ ],int m)         //move函式主要作該陣列的內部變化

   {      int c[]=new int[a.length+m];             //定義一個數組c把陣列arr整體右移後的存放其中

           int l=a.length-1;

  for(int j=l;j>=0;j--)    //將整個陣列中的元素向右移mo個位置

{

  c[j+m]=a[j];

}

for(int k=l+1;k<=l+m;k++)  //將a[l+1:l+m]這一串整數左移l+1個位置

c[k-l-1]=c[k];

for(int p=0;p<a.length;p++)

System.out.print(c[p]+" ");

   }

}