有序連結串列的歸併(資料結構)
阿新 • • 發佈:2018-12-15
連結串列的歸併有好多種做法,連結串列的難度並不是在思想上,而是在程式碼的實現上,指標的來回轉換很容易將人弄混亂,一會不知道指標到哪了,一個好好的指標可能在不知不覺中就變成了一個野指標,沒有物件也沒有記憶體。。。
以SDUT的一個題目為例來解釋一下連結串列的歸併:
資料結構實驗之連結串列四:有序連結串列的歸併
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
分別輸入兩個有序的整數序列(分別包含M和N個數據),建立兩個有序的單鏈表,將這兩個有序單鏈表合併成為一個大的有序單鏈表,並依次輸出合併後的單鏈表資料。
Input
第一行輸入M與N的值;
第二行依次輸入M個有序的整數;
第三行依次輸入N個有序的整數。
Output
輸出合併後的單鏈表所包含的M+N個有序的整數。
Sample Input
6 5
1 23 26 45 66 99
14 21 28 50 100
Sample Output
1 14 21 23 26 28 45 50 66 99 100
Hint
不得使用陣列!
這個題的思想很容易就可以想到,要麼就建立第三個連結串列來進行對前兩個連結串列的輸出,或者比較複雜的就是用第三個連結串列把前兩個連結串列中的每一個結點都“扣”下來連線到第三個連結串列上,然後輸出第三個連結串列。還有一種方法是對第一種方法進行了優化,思想一樣,但是程式碼效率較高
先附上第一種:(用c++寫的,還沒學c++的童鞋也可以看的,c和c++沒有什麼區別的,程式碼的主體是一樣的)
#include<bits/stdc++.h> using namespace std; typedef struct node { int data; struct node*next; }tree; int main() { ios::sync_with_stdio(false); struct node*head1,*head2,*p,*q,*s,*tail1,*tail2,*head3,*tail; head1=new tree; head2=new tree; head1->next=NULL; head2->next=NULL; tail1=head1; tail2=head2; int m,n,i; cin>>m>>n; for(i=0;i<=m-1;i++) { p=new tree; cin>>p->data; p->next=NULL; tail1->next=p; tail1=p; } for(i=0;i<=n-1;i++) { q=new tree; cin>>q->data; q->next=NULL; tail2->next=q; tail2=q; } head3=new tree; head3->next=NULL; tail=head3; p=head1->next; q=head2->next; int c1=0,c2=0; while(p&&q) { if(p->data<q->data) { s=new tree; s->data=p->data; p=p->next; tail->next=s; tail=s; c1++; } else { s=new tree; s->data=q->data; q=q->next; tail->next=s; tail=s; c2++; } } for(i=c1;i<=m-1;i++) { s=new tree; s->data=p->data; p=p->next; tail->next=s; tail=s; } for(i=c2;i<=n-1;i++) { s=new tree; s->data=q->data; q=q->next; tail->next=s; tail=s; } p=head3->next; while(p) { if(p->next==NULL) { cout<<p->data<<endl; } else { cout<<p->data<<" "; } p=p->next; } return 0; }
接下來是第二種程式碼,想挑戰一下自己的童鞋可以好好理解一下哦:
(C的程式碼)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct linshi
{
int data;
struct linshi *next;//建立連結串列所用的結構體
};
struct linshi *head1,*head2,*p,*q,*r,*s;//定義全域性變數,可以省略函式間傳遞指標這個麻煩的過/ //程
void set(int); //函式宣告
void chuli(void);
void set(int k)//建立連結串列的過程就不多解釋了..
{
int a;
while(k--)
{
scanf("%d",&a);
q=(struct linshi *)malloc(sizeof(struct linshi)*1);
q->data=a;
p->next=q;
q->next=NULL;
p=p->next;
}
return ;
}
void chuli(void)
{
r=head2->next;
while(r!=NULL)
{
s=(struct linshi *)malloc(sizeof(struct linshi)*1);
s->data=r->data;
s->next=NULL;
p=head1->next;
q=head1;
while(p!=NULL)
{
if(s->data<p->data)
{
q->next=s;
s->next=p;
break;
}
q=p;
p=p->next;
}
if(p==NULL)
{
s->next=NULL;
q->next=s;
}
r=r->next;
}
p=head1->next;
while(p!=NULL)
{
printf("%d",p->data);
if(p->next!=NULL)
{
printf(" ");
}
p=p->next;
}
printf("\n");
}
int main()
{
int m=0,n=0;
head1=(struct linshi *)malloc(sizeof(struct linshi)*1);
head1->next=NULL;
head2=(struct linshi *)malloc(sizeof(struct linshi)*1);
head2->next=NULL;
p=(struct linshi *)malloc(sizeof(struct linshi)*1);
q=(struct linshi *)malloc(sizeof(struct linshi)*1);
r=(struct linshi *)malloc(sizeof(struct linshi)*1);
scanf("%d%d",&m,&n);
p=head1;
set(m);
p=head2;
set(n);
chuli();
return 0;
}
第三種程式碼(依舊是C++):
#include<bits/stdc++.h>
using namespace std;
typedef struct node
{
int data;
struct node*next;
}tree;
int main()
{
ios::sync_with_stdio(false);//加速輸入輸出
int m,n;
cin>>m>>n;
struct node *head1,*head2,*p,*q,*tail1,*tail2;
head1=new tree;
head2=new tree;
head1->next=NULL;
head2->next=NULL;
tail1=head1;
tail2=head2;
for(int i=0;i<=m-1;i++)//建立連結串列
{
p=new tree;
cin>>p->data;
p->next=NULL;
tail1->next=p;
tail1=p;
}
for(int i=0;i<=n-1;i++)//建立連結串列
{
q=new tree;
cin>>q->data;
q->next=NULL;
tail2->next=q;
tail2=q;
}
p=head1->next;
q=head2->next;
struct node * head3,* tail;
head3=new tree;
head3->next=NULL;
tail=head3;
while (p && q)
{
if (p->data > q->data)
{
tail->next = q;
tail = q;
q = q->next;
}
else
{
tail->next = p;
tail = p;
p = p->next;
}
}
if (p)//連線未輸出的連結串列的結點
tail->next = p;
if (q)
tail->next = q;
p=head3->next;
while(p)//輸出連結串列三
{
if(p->next==NULL)
{
cout<<p->data<<endl;
}
else
{
cout<<p->data<<" ";
}
p=p->next;
}
return 0;
}
還請大佬們多多指點!