3867——Earthstone: Easy Version
Earthstone is a famous online card game created by Lizard Entertainment. It is a collectible card game that revolves around turn-based matches between two opponents. Players start the game with a substantial collection of basic cards, but can gain rarer and more powerful cards through purchasing packs of additional cards, or as rewards for competing in the arena. Card packs can be purchased with gold, an in-game currency rewarded for completing random daily quests and winning matches, or by using real money in the in-game store.
Each Earthstone battle is a one on one turn-based match between two opponents. During a player's turn, he can choose to play any of his cards and command the minions to attack targets. Those played cards will be placed on the table as they are 'summoned' as minions. Each card has two basic attributes:
- Attack Ai: If a minion attacks a character or was attacked, it will deal Ai points of damage to the opponent. A character whose attack value is zero cannot actively attack.
- Health Hi: The minion has Hi points of initial health. After being damaged, the minion's health will decrease by the corresponding damage value. The minion will be killed and discarded if its health is less than or equal to zero.
- If a minion attacks another minion, both of them will receive damage simultaneously.
Given two minions, please calculate the result if the first minion attacked the second one.
Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
There are four integers A1, H1, A2 and H2 (0 <= A1, A2 <=10, 1 <= H1, H2 <= 10), which are the attributes of two minions.
Output
For each test case, output "Invalid" (without quotes) if the first minion cannot attack, otherwise output the minions attributes as the format in input. If the minion is killed, output "Discard" instead (without quotes).
Sample Input
3 3 3 2 4 3 2 2 5 0 3 2 2
Sample Output
3 1 2 1 Discard 2 2 Invalid
題意:第一個數為組數,後跟4個數,前兩個為第一隻怪獸的攻擊力和血量,後兩個為第二隻怪獸的攻擊力和血量。他們相互攻擊剩下的血量為多少。如果第一個怪不能攻擊,則輸出“Invalid”(沒有引號),否則輸出怪屬性作為輸入的格式。如果怪被殺死,輸出“Discard”(不帶引號)。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
int main()
{
int t,a1,a2,b1,b2;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d%d",&a1,&a2,&b1,&b2);
if(a1==0)
{
printf("Invalid\n");
continue;
}
a2-=b1;
b2-=a1;
if(a2<=0)
printf("Discard ");
else
printf("%d %d ",a1,a2);
if(b2<=0)
printf("Discard\n");
else
printf("%d %d\n",b1,b2);
}
}