1. 程式人生 > >java—學生類

java—學生類

Description

有一個學生類的結構如下:
class Student {
	private int no;
	private String name;
        private int score;
	
	public Student(int _no, String _name, int _score) {
		no = _no;
		name = _name;
                score = _score;
	}
        public int getNo() {return no;}
        public String getName() {return name;}
        public int getScore() {return score;}
	
	public void print(){
		System.out.println(no + " "+name+" "+score);
	}
}

請構造main函式完成如下功能:
從鍵盤中讀入三個學生的資訊,比較他們的成績,按照成績由高到低排列輸出

Input

三個學生的學號、姓名、成績

Output

由高到低排列輸出的三個學生資訊

Sample Input

1 wang 89
2 liu 78
3 ma 90

Sample Output

3 ma 90
1 wang 89
2 liu 78
import java.util.*;

public class Main {

    public static void main(String[] args) {

        Scanner input=new Scanner(System.in);

        Student s[]=new Student[4];

        for
(int i=0;i<3;i++) { int a=input.nextInt(); String n =input.next(); int b=input.nextInt(); s[i]=new Student(a,n,b); } for(int i=0;i<=2;i++) { for(int j=i+1;j<3;j++) if(s[i].getScore()<s[j].getScore
()) { Student ss=new Student(0,"",0); ss=s[i]; s[i]=s[j]; s[j]=ss; } } for(int i=0;i<=2;i++) { s[i].print(); } } }