1. 程式人生 > >Dropping tests (最大化平均值)

Dropping tests (最大化平均值)

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is 

. However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n

 positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

n代表n組測試資料,k表示可捨棄k組,以求最大平均值

思路:

起初想到是對a/b進行排序,從大到小貪心進行選取,但是發現不對。。。。

實際上,可以用二分搜尋法搜尋所求的這個最大值,假設這個最大平均值為x。那麼如圖所示:

  由圖可知,該問題就轉換成了列舉x的值使S集合內(100*ai-xbi)之和大於0,則該x值符合要求,但需求最大的x,依次二分列舉查詢即可。此時s的集合範圍便是(100*ai-x*bi)前n-k大的數。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define p 1010
#define minn 1e-10
using namespace std;
int n,m;
double a[p],b[p],num[p];
double check(double x){
    memset(num,0,sizeof(num));
    for(int i=0;i<n;i++){
        num[i]=100*a[i]-x*b[i];
    }
    sort(num,num+n);
    double sum=0;
    for(int i=m;i<n;i++){
        sum+=num[i];
        //printf("num=%.1f sum=%.1f\n",num[i],sum);
    }
    //printf("sum=%.1f\n",sum);
    return sum;
}
int main(){

    while(scanf("%d%d",&n,&m)!=EOF){
    if(n==0&&m==0)
            break;
    for(int i=0;i<n;i++){
        scanf("%lf",&a[i]);
    }
     for(int i=0;i<n;i++){
        scanf("%lf",&b[i]);
    }
    double l=0,r=100;
    while(r-l>minn){
        double mid=(l+r)/2;
        //printf("l=%.1f r=%.1f mid=%.1f\n",l,r,mid);
        if(check(mid)>0){//若前n-k大的數和大於0,則說明該x值可能合適,但也許能再大
            l=mid;
            //printf("l=%.2f\n",l);
        }
        else{
            r=mid;
        }
    }
    printf("%.0f\n",l);
    }
    }