1. 程式人生 > >1054 The Dominant [email protected]

1054 The Dominant [email protected]

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictlydominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

對矩陣中出現的每個數位操作。每一位上為1,陣列中相應位置+1;反之,-1。

因為 dominant color大於矩陣的一半,所以最後陣列中的數(正數代表一,負數代表零)就是答案。

#include <iostream>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <string>
#include <set>
#include <stack>
#include <algorithm>
#include <iomanip>
#define MAXN 100004

using namespace std;

int cnt[25];

int main(){
    int n,m;
    while(cin >> m >> n){
        memset(cnt,0,sizeof(cnt));
        int val;
        for(int i=0;i<m;++i){
            for(int j=0;j<n;++j){
                cin >> val;
                int pos = 0;
                for(int pos=0;pos<24;++pos){
                    if(val & 1) ++cnt[pos];
                    else --cnt[pos];
                    val >>= 1;
                }
            }
        }
        int weight = 1;
        int ans = 0;
        for(int i=0;i<24;++i){
            if(cnt[i] < 0) ans += weight*0;
            else if(cnt[i] > 0) ans += weight*1;
            weight *= 2;
        }
        cout << ans << endl;
    }
	return 0;
}