1. 程式人生 > >HDU-2095 find your present (異或運算)

HDU-2095 find your present (異或運算)

                                     find your present (2)

                           Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)                                                 Total Submission(s): 28873    Accepted Submission(s): 11315

Problem Description

In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

Input

The input file will consist of several cases.  Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output

For each case, output an integer in a line, which is the card number of your present.

Sample Input

5

1 1 3 2 2

3

1 2 1

0

Sample Output

3

2

Hint

Hint use scanf to avoid Time Limit Exceeded

Author

8600

Source

題意:

給你1個n,然後下一行有n個數,問你這些數中哪個出現的次數是奇數次(只有1組),輸出它。

思路:

上來就暴力了, 直接開陣列,結果記憶體暴了。

直接用異或運算即可。因為兩個相同的數異或的值為0。因為只有一組是奇數個。所以兩兩抵消,最後就剩下那一個奇數次的數了。

異或的運演算法則:

1、a^b = b^a

2、(a^b)^c = a^(b^c)

3、a^b^a = b

異或的兩個性質

1、0^n = n

2、n^n = 0

程式碼:

#include<bits/stdc++.h>
using namespace std;

int main()
{
	int n;
	while(cin >> n) {
		if(n == 0)break;
		int ans =  0;
		while(n--) {
			int t;
			scanf("%d", &t);
			ans ^= t;
		}
		cout << ans << endl;
	}
	return 0;
}