1. 程式人生 > >2749-區域內點的個數-JAVA

2749-區域內點的個數-JAVA

區域內點的個數

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

X晚上睡不著的時候不喜歡玩手機,也不喜歡打遊戲,他喜歡數星星。

Input

 多組輸入。

每組先輸入一個整數N(N <= 10000),接著輸入兩個點代表矩形的左下點B(x,y)和右上點T(x,y),然後輸入N個(X,Y)代表N顆星星。問有多少顆星星在窗子內部,在窗邊上的不計。

Output

 輸出一個整數,代表有多少顆星星在窗子內部。

Sample Input

3
0 1
3 4
1 1
2 2
3 3

Sample Output

1

Hint

Source

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		while (scanner.hasNext()) {
			int t = scanner.nextInt();
			int a = scanner.nextInt();
			int b = scanner.nextInt();
			int x = scanner.nextInt();
			int y = scanner.nextInt();
			int court = 0;
			for (int i = 0; i < t; i++) {
				int m = scanner.nextInt();
				int n = scanner.nextInt();
				if (m > a && m < x && n > b && n < y) {
					court++;
				}
			}
			System.out.println(court);
		}
	}
}