1. 程式人生 > >HDU-1069 Monkeys and Banana

HDU-1069 Monkeys and Banana

原題: A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. Input The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values xi, yi and zi. Input is terminated by a value of zero (0) for n. Output For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”. Sample Input 1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0 Sample Output Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342 題意: 有n種木塊,每一種木塊都有長寬高,並且有無限多個,現在要求你用這些木塊來搭積木,要求高度最高。搭積木的要求是,只有兩個木塊的接觸面上邊的那個長和寬都要小於在下邊的木塊的長和寬。搭積木的過程中可以調整每一個木塊的角度,使其長寬高相互變換。 題解: 由於每一種木塊都有無限個,且搭積木時可以調整角度,相當於可以衍生出來6種不同的積木,而又因為長寬即使相同也不能搭在上面,所以可以將無限個每種木塊抽象出6個不同的木塊,剩下的就是按照題目進行動態規劃處理了: dp【i】=max(dp【i】,dp【j】+high) 如果滿足題意,並且此方法搭出的高度比原先搭出的高度要高,則記錄新方法。 (更多細節見程式碼) 附上AC程式碼:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
struct t
{
    int x,y,z;
}st[200];//定義結構體
int n,dp[200];
bool cmp(t a,t b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}//按照x的大小從小到大排序
int main()
{
    int cas=1;
    while(cin>>n,n)
    {
        int x,y,z,k=0;
        for(int i=1;i<=n;++i)
        {
            cin>>x>>y>>z;
            /*
            因為說了每一種都有無限多個,並且可以顛倒順序,
            有6中不同的組合方式,而且因為如果兩個的面積完全相同也不能夠踩上去,
            所以無限多個積木就可以想成以下6種木塊且唯一存在
            */
            st[k].x=x,st[k].y=y,st[k++].z=z;
            st[k].x=x,st[k].y=z,st[k++].z=y;
            st[k].x=y,st[k].y=x,st[k++].z=z;
            st[k].x=y,st[k].y=z,st[k++].z=x;
            st[k].x=z,st[k].y=y,st[k++].z=x;
            st[k].x=z,st[k].y=x,st[k++].z=y;
        }
        sort(st,st+k,cmp);
        for(int i=0;i<k;++i)
        {
            dp[i]=st[i].z;//初始化每一個木塊的起始高度
        }
        for(int i=0;i<k;i++)
        {
            //對於第i個木塊在其之前的所有木塊種找出最佳的排列組合使高度最高
            for(int j=0;j<i;j++)
            {
                if(st[i].x>st[j].x&&st[i].y>st[j].y&&dp[i]<dp[j]+st[i].z)
                //如果滿足條件:長寬都比其大,並且放上去後比原先的方法的高度高
                    dp[i]=dp[j]+st[i].z;
            }
        }
        sort(dp,dp+k);//輸出最大的那一個高度
        printf("Case %d: maximum height = %d\n",cas++,dp[k-1]);
    }
    return 0;
}

歡迎評論!