1. 程式人生 > >(方法)給定一個有序數列,通過中序遍歷利用陣列建立起二叉查詢樹(PAT1064)

(方法)給定一個有序數列,通過中序遍歷利用陣列建立起二叉查詢樹(PAT1064)

建樹的時候,有時候沒有必要大費周章地去通過結點構造一棵二叉樹,我們利用各結點之間的數學關係,通過陣列就可以實現一棵二叉樹,假設結點序列為a,那麼其左子就是a*2,右子就是a*2+1

由於二叉樹中序遍歷的結果是一串有序序列,那麼我們可以通過中序來得到一棵二叉樹

void leveltra(int root) {   //從根節點開始遍歷
	if (root > n) {
		return;
	}
	leveltra(root * 2);  //左節點遞迴
	BST[root] = a[index++];
	leveltra(root * 2 + 1);  //右節點遞迴
}

//a表示有序序列,BST表示二叉搜尋樹

相關例題如下:

1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

因為給出的是有序序列,所以我們可以以各個結點的位置序號為下標,來構造二叉樹

如果按順序輸出結果,那麼就是二叉樹層序遍歷的結果

實現程式碼如下:

#include <iostream>
#include <algorithm>
using namespace std;

int a[1010];
int levelTravese[1010];
int index = 1;   
int n = 0;

void leveltra(int root) {   //從根節點開始遍歷
	if (root > n) {
		return;
	}
	leveltra(root * 2);  //左節點
	levelTravese[root] = a[index++];
	leveltra(root * 2 + 1);  //右節點
}

int main() {

	cin >> n;  //讀入有多少個數
	for (int i = 1; i <= n; ++i) {
		cin >> a[i];
	}
	sort(a+1, a + n+1);   //進行排序
	leveltra(1);

	for (int j = 1; j <= n; ++j) {
		if (j == n) {
			cout << levelTravese[j];
		}
		else {
			cout << levelTravese[j] << " ";
		}
	}

	system("PAUSE");
	return 0;
}