PAT 1100 Mars Numbers
阿新 • • 發佈:2018-12-19
People on Mars count their numbers with base 13:
- Zero on Earth is called "tret" on Mars.
- The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
- For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.
For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.
Output Specification:
For each number, print in a line the corresponding number in the other language.
Sample Input:
4
29
5
elo nov
tam
Sample Output:
hel mar
may
115
13
#include<cstdio>
#include<set>
#include<map>
#include<string>
#include<iostream>
#include<cctype>
using namespace std;
string gewei[13]={"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string shiwei[13]={"tret","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string NumToStr[170];
map <string,int >StrToNum;
//初始化map
void init(){
for(int i=0;i<13;i++){
NumToStr[i]=gewei[i];
StrToNum[gewei[i]]=i;
NumToStr[13*i]=shiwei[i];
StrToNum[shiwei[i]]=13*i;
}
for(int i=1;i<13;i++){
for(int j=1;j<13;j++){
string str=shiwei[i]+" "+gewei[j];
NumToStr[i*13+j]=str;
StrToNum[str]=i*13+j;
}
}
}
//字串轉化為數字
int convert(string s,int &sum){
sum=0;
for(int i=0;i<s.length();i++)
sum=sum*10+s[i]-'0';
return sum;
}
int main(){
init();
int T;
scanf("%d%*c",&T);
while(T--){
int sum;
string s;
getline(cin,s);
if(isdigit(s[0])) cout<<NumToStr[convert(s,sum)]<<endl;
else cout<<StrToNum[s]<<endl;
}
return 0;
}