【POJ】2364Balanced Lineup-(RMQ基礎)
Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height. Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group. Input Line 1: Two space-separated integers, N and Q Output Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range. Sample Input
Sample Output
Source |
題目大意:給出n個數,要求出下面給出m個提問中的區間內的(最大值-最小值)
思路:基礎的RMQ問題,
程式碼:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=50000+1000;
int dmax[MAXN][20];
int dmin[MAXN][20];
int d[MAXN];
void initMax(int n,int d[])
{
for(int i=1;i<=n;i++)dmax[i][0]=d[i];
for(int j=1;(1<<j)<=n;j++)
for(int i=1;i+(1<<j)-1<=n;i++)
dmax[i][j]=max(dmax[i][j-1],dmax[i+(1<<(j-1))][j-1]);
}
int getMax(int L,int R)
{
int k=0;
while((1<<(k+1))<=R-L+1)k++;
return max( dmax[L][k],dmax[R-(1<<k)+1][k] );
}
void initMin(int n,int d[])
{
for(int i=1;i<=n;i++)dmin[i][0]=d[i];
for(int j=1;(1<<j)<=n;j++)
for(int i=1;i+(1<<j)-1<=n;i++)
dmin[i][j]=min( dmin[i][j-1],dmin[i+(1<<(j-1))][j-1] );
}
int getMin(int L,int R)
{
int k=0;
while((1<<(k+1))<=R-L+1)k++;
return min( dmin[L][k],dmin[R-(1<<k)+1][k] );
}
int main()
{
int n,q;
while(scanf("%d%d",&n,&q)==2)
{
for(int i=1;i<=n;i++)
scanf("%d",&d[i]);
initMax(n,d);
initMin(n,d);
while(q--)
{
int L,R;
scanf("%d%d",&L,&R);
printf("%d\n",getMax(L,R)-getMin(L,R));
}
}
return 0;
}