1. 程式人生 > >poj 2777Count Color(區間染色)

poj 2777Count Color(區間染色)

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.  There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:  1. "C A B C" Color the board from segment A to segment B with color C.  2. "P A B" Output the number of different colors painted between segment A and segment B (including).  In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

Source

兩種操作,第一種給某個區間染某種顏色,第二種問你區間內有多少種顏色

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define lson 2*i,l,m
#define rson 2*i+1,m+1,r
#define maxn 100010
bool vis[35];
int cnt;
int color[maxn*4];
void build(int i,int l,int r)
{
    color[i]=1;
    if(l==r)
    return ;
    int m=(l+r)/2;
    build(lson);
    build(rson);

}
void pushdown(int i)
{
    if(color[i]>0)
    color[i*2]=color[i*2+1]=color[i];
}
void pushup(int i)
{
    if(color[i*2]==-1||color[i*2+1]==-1)
    color[i]=-1;
    else if(color[i*2]==color[i*2+1])
    color[i]=color[i*2];
    else
    color[i]=-1;
}
void update(int ql,int qr,int v,int i,int l,int r)
{
    if(ql<=l&&r<=qr)
    {
        color[i]=v;
        return ;
    }
    pushdown(i);
    int m=(l+r)/2;
    if(ql<=m)
    update(ql,qr,v,lson);
    if(m<qr)
    update(ql,qr,v,rson);
    pushup(i);
}
void query(int ql,int qr,int i,int l,int r)
{
    if(color[i]>0)
    {
        if(vis[color[i]]==false)
        cnt++;
        vis[color[i]]=true;
        return ;

    }
    int m=(l+r)/2;
    if(ql<=m)
    query(ql,qr,lson);
    if(m<qr)
    query(ql,qr,rson);
}
int main()
{int n,t,q;
while(~scanf("%d%d%d",&n,&t,&q))
{build(1,1,n);
while(q--)
{
    char str[10];
    scanf("%s",str);
    if(str[0]=='C')
    {
        int x,y,z;
        scanf("%d%d%d",&x,&y,&z);
        update(x,y,z,1,1,n);
    }
    else if(str[0]=='P')
    {
        int x,y;
        scanf("%d%d",&x,&y);
        memset(vis,0,sizeof(vis));
        cnt =0;
        query(x,y,1,1,n);
        printf("%d\n",cnt);
    }
}
}
    return 0;
}