1. 程式人生 > >Piggy-Bank

Piggy-Bank

這是一道完全揹包模板題。它的大意就是說給你一個硬幣罐子的容量,然後給你不同種類的硬幣,價值和重量各不相同。然後採取01揹包的思想,不過要先將dp設定為最大值,然後再按照從小的重量到極限的重量來dp就可以了;

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.  But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int dp[100010],v[1100],w[1100];
int  inf=999999;
int main()
{
    int t,i,j,k,m,n;
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,inf,sizeof(dp));
        scanf("%d%d%d",&m,&n,&k);
        for(i=1;i<=k;i++)
        {
            scanf("%d%d",&v[i],&w[i]);
        }
        dp[0]=0;
        for(i=1;i<=k;i++)
        {
            for(j=w[i];j<=n-m;j++)
            {
                dp[j]=min(dp[j],dp[j-w[i]]+v[i]);
            }
        }
        if(dp[n-m]<inf)
        {
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[n-m]);
        }
        else
        {
            printf("This is impossible.\n");
        }
    }
        return 0;
}