1. 程式人生 > >POJ - 3259 Wormholes(多種方法求負權迴路)+譯文

POJ - 3259 Wormholes(多種方法求負權迴路)+譯文

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: N, M, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.
Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
t譯文:農夫約翰在探索他的許多農場,發現了一些驚人的蟲洞。蟲洞是很奇特的,因為它是一個單向通道,可讓你進入蟲洞的前達到目的地!他的N(1≤N≤500)個農場被編號為1..N,之間有M(1≤M≤2500)條路徑,W(1≤W≤200)個蟲洞。作為一個狂熱的時間旅行FJ的愛好者,他要做到以下幾點:開始在一個區域,通過一些路徑和蟲洞旅行,他要回到最開時出發的那個區域出發前的時間。也許他就能遇到自己了:)。為了幫助FJ找出這是否是可以或不可以,他會為你提供F個農場的完整的對映到(1≤F≤5)。所有的路徑所花時間都不大於10000秒,所有的蟲洞都不大於萬秒的時間回溯。

 
輸入
第1行:一個整數F表示接下來會有F個農場說明。
每個農場第一行:分別是三個空格隔開的整數:N,M和W
第2行到M+1行:三個空格分開的數字(S,E,T)描述,分別為:需要T秒走過S和E之間的雙向路徑。兩個區域可能由一個以上的路徑來連線。
第M +2到M+ W+1行:三個空格分開的數字(S,E,T)描述蟲洞,描述單向路徑,S到E且回溯T秒。
輸出
F行,每行代表一個農場
每個農場單獨的一行,” YES”表示能滿足要求,”NO”表示不能滿足要求。
NO
YES

哈哈,要想回到原點。。。蟲洞可以讓 你回到過去,就相當於一個負權。。。然後判斷是否存在負環,即走走走。。。然後又走回去了,,,

方法一:Bellmand---Ford
 

#include<stdio.h>
#define INF 0x3f3f3f3f
int dis[10000],bak[10000],u[10000],v[10000],t[10000],check,flag,n,m,w;
int main()
{
    int f;
    scanf("%d",&f);
    while(f--)
    {
        scanf("%d%d%d",&n,&m,&w);
        for(int i=1;i<=m;i++)
            scanf("%d%d%d",&u[i],&v[i],&t[i]);
        for(int i=m+1;i<=m+w;i++)
        {
            scanf("%d%d%d",&u[i],&v[i],&t[i]);   //蟲洞時間是負的·且單向
            t[i]=-t[i];
        }
        for(int i=1;i<=n;i++)
            dis[i]=INF;
        dis[1]=0;
        for(int k=1;k<n;k++)
        {
            for(int i=1;i<=n;i++)bak[i]=dis[i];  //將dis陣列備份,可省時,提前跳出迴圈
            for(int i=1;i<=m;i++)
            {   
                if(dis[v[i]]>dis[u[i]]+t[i])    //農場兩個方向都要判斷
                    dis[v[i]]=dis[u[i]]+t[i];
                if(dis[u[i]]>dis[v[i]]+t[i])
                    dis[u[i]]=dis[v[i]]+t[i];
            }
            for(int i=m+1;i<=m+w;i++)
            {
                if(dis[v[i]]>dis[u[i]]+t[i])    //注意!!!!!!!!!!!!!從v[i]-u[i]是正的,方向別弄錯了。。
                    dis[v[i]]=dis[u[i]]+t[i];
            }
            check=0;
            for(int i=1;i<=n;i++)
                if(bak[i]!=dis[i])
            {
                check=1;
                break;
            }
            if(check==0)break;
        }
        flag=0;
        for(int i=1;i<=m;i++)               //蟲洞不用判斷,因為本身就是負的,判斷m就好了.加上也行。
            if(dis[v[i]]>dis[u[i]]+t[i])flag=1;
        if(flag)
            printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

方法二(floyd):

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int map[505][505],n,m,k,num=0;
int floyd()
{
    int i,j,k,f=0;
    for(k=1;k<=n;k++)
        for(i=1;i<=n;i++){
            for(j=1;j<=n;j++)
            {
                int t=map[i][k]+map[k][j];
                if(map[i][j]>t)map[i][j]=t;
                /*map[i][j]=min(map[i][j],map[i][k]+map[k][j]);*/   //注意這裡,用錯了會超時!!!!不用min就跑了1688ms,,,,
            }
            if(map[i][i]<0)return 1;
    }
    return f;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int i,j,a,b,c;
        scanf("%d%d%d",&n,&m,&k);
        memset(map,0x3f3f3f3f,sizeof(map));
        for(i=1;i<=n;i++)map[i][i]=0;
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(c<map[a][b])map[a][b]=map[b][a]=c;
        }
        for(i=1;i<=k;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            map[a][b]=-c;
        }
        num++;
        int f=floyd();
        if(!f)printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}

轉載自:https://blog.csdn.net/zitian246/article/details/76082393