1. 程式人生 > >1093 登入密碼驗證

1093 登入密碼驗證

Description

編寫一個程式,模擬使用者登入系統的密碼驗證過程。系統提供給使用者的密碼長度最長為20個字元,若密碼輸入錯誤可以再次輸入。但為了保證使用者密碼安全,若連續輸入密碼錯誤超過5次就會鎖定賬號一段時間。

Input

輸入為若干個串,至EOF結束。輸入的第一個串是使用者的正確密碼,後面的串為模擬使用者登入時的輸入的密碼。

Output

每次輸入錯誤的密碼,輸出一個“Wrong!”,若輸入的密碼為正確的,輸出一個“Welcome!”,並結束密碼測試。若前5次輸入的密碼都是錯誤的,則後面的輸入中不管是否有正確的密碼都輸出“Out of limited!”。

Sample Input

abcdefg 123456 kkkkkkkk abcdefg Sample Output Wrong! Wrong! Welcome!

HINT

輸入可以用scanf("%s")處理,密碼比較用字串的比較可以完成。

Append Code

#include<stdio.h>
#include<string.h>
int main()
{
    int i=0;
    char ch[21],th[21];
    scanf("%s",ch);
    while(scanf("%s",th)!=EOF)
    {
        i++;
        if(i<=5)
        {
            if(strcmp(th,ch)==0)
            {
                printf("Welcome!\n");
                break;
            }
            else
                printf("Wrong!\n");
        }
       else
       {
           printf("Out of limited!\n");
       }
    }
    return 0;
}