1. 程式人生 > >Shortest Prefixes(字典樹)

Shortest Prefixes(字典樹)

Description
A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.
In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”.
An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”.
Input


The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate
Sample Output
carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona
題意
輸入若干單詞,求這些單詞中每個單詞的最短字首----這個字首就只這一個單詞有。
如果沒有這樣的最短字首,就輸出這一整個單詞。
題解

把這些單詞建成一個字典樹,在建樹的過程中,每經過一個節點,就用一個輔助陣列把這個節點加一次,vis[root],存的是從根節點開始到下標為root的節點這一路的字母即字首,有多少個單詞有這樣的字首。

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <sstream>
#include <cstdio>
#include <vector>
#include <string>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <set>
#define INF 0x3f3f3f3f
#define fori(a,b) for(int i=a;i<b;i++)
#define forj(a,b) for(int j=a;j<b;j++)
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long LL;
//const double PI = acos(-1);
const int MAX=1e5;
char s[1111][50];
int trie[MAX][30];  //trie[i][j]=k,下標為i,字母為j的節點的j的後邊字母的下標 
int vis[MAX];       
int cnt=1;
void build_trie(char s[])    //建樹
{
    int root = 0;
    fori(0,s[i]){
        int next = s[i]-'a';
        if(!trie[root][next])
            trie[root][next]=cnt++;
        root=trie[root][next];
        vis[root]++;
    }
}

string query(char s[])    //查詢
{
    string ans;
    int root=0;
    fori(0,s[i]){
        if(vis[root]==1)
            return ans;
        int next=s[i]-'a';
        ans+=s[i];
        root=trie[root][next];
    }
    return ans;
}
int main()
{
    mem(trie,0);
    mem(vis,0);
    int n=0;
    while(scanf("%s",s[n])!=EOF){
        build_trie(s[n]);
        n++;
    }
    fori(0,n){
        cout << s[i] << " "<< query(s[i]) << endl;
    }
}