1. 程式人生 > >FAFU OJ 博弈(10)乘法遊戲

FAFU OJ 博弈(10)乘法遊戲

博弈(10)乘法遊戲
Time Limit: 1000MS Memory Limit: 65536KB
Total Submissions: 46 Accepted: 28
Share Description:       Z and C play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Z always starts with p = 1, does his multiplication, then C multiplies the number, then Z and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n. Input: Each line of input contains one integer number n. Output: For each line of input output one line either 
       
      Z wins. 
       
      or 
       
      C wins. 
       
      assuming that both of them play perfectly. 
       Sample Input: 162 17 34012226 Sample Output: Z wins. C wins. Z wins. Source:
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
  double n;
  while(scanf("%lf",&n)!=EOF)
  {
     while(n>18) n/=18;
     if(n<=9)
     {
         printf("Z wins.\n");
     }
     else
     {
         printf("C wins.\n");
     }
  }
  return 0;
}