1. 程式人生 > >Mayor's posters (線段樹+離散化+加思維)

Mayor's posters (線段樹+離散化+加思維)

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 
InputThe first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i
 and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.OutputFor each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 
Sample Input
1
5
1 4
2 6
8 10
3 4
7 10
Sample Output
4

題意:給你一個長 10000000 的牆,讓你在上面貼海報,輸入t,表示有幾組資料,下面有一個數字n,表示有n長海報,下面n行,表示每張海報的要貼的區間,從上到下按照順序貼,看看到最後有幾張海報能露出來(露出部分也算)

思路:線段樹,既是這個區間的懶惰標記值,也就第幾張海報,到最後查詢一次就行了,只有查詢到這個區間的懶惰標記值不為0,就可以返回了,由於給出的牆太長,但是給你的海報上數就10000,所以你可以離散化;

程式碼:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define Max 10010

struct node
{
	int x,y;
}s[Max];
int stu[8*Max];
int n;
int book[Max];
int a[2*Max];
void build(int root,int star,int end)
{
	stu[root] = 0;
	if(star==end)
		return ;
	int mid = (star+end)/2;
	build(root*2,star,mid);
	build(root*2+1,mid+1,end);
}

void down(int root)
{
	stu[2*root] = stu[2*root+1] = stu[root];
	stu[root] = 0;
}
void updat(int root,int star,int end,int x,int y,int val)
{
	if(star>=x&&end<=y)
	{
		stu[root] = val;
		return ;
	}
	if(stu[root])
		down(root);
	int mid = (star+end)/2;
	if(x<=mid)
		updat(root*2,star,mid,x,y,val);
	if(y>mid) updat(root*2+1,mid+1,end,x,y,val);
}

void Qury(int root,int star,int end)
{
	if(star==end&&stu[root]==0)
		return ;
	if(stu[root])
	{
		book[stu[root]] = 1;
		return ;
	}
	int mid = (star+end)/2;
	Qury(root*2,star,mid);
	Qury(root*2+1,mid+1,end);
}
int main()
{
	int i,j,t;
	scanf("%d",&t);
	while(t--)
	{
		int x,y;
		scanf("%d",&n);
		memset(book,0,sizeof(book));
		int ma = 0;
		int tt = 0;
		for(i = 1;i<=n;i++)
		{
			scanf("%d%d",&s[i].x,&s[i].y);
			a[tt++] = s[i].x;
			a[tt++] = s[i].y;	
		}
		sort(a,a+tt);
		for(i = 1;i<=n;i++)
		{
			s[i].x = (lower_bound(a,a+tt,s[i].x)-a) + 1;
			s[i].y = (lower_bound(a,a+tt,s[i].y)-a) + 1;
		}
		build(1,1,tt);
		for(i = 1;i<=n;i++)
			updat(1,1,tt,s[i].x,s[i].y,i);
		Qury(1,1,tt);
		int sum = 0;
		for(i = 1;i<=n;i++)
			if(book[i])
				sum++;
		printf("%d\n",sum);
	}
	return 0;
}