1. 程式人生 > >甲級PAT 1070 Mooncake (排序+貪心)

甲級PAT 1070 Mooncake (排序+貪心)

1070 Mooncake (25 分)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

題目要求 :

給定所有種類的月餅的庫存量,總售價,以及市場最大的銷售量。在不超過市場最大銷售量的情況下如何售賣獲取最大利潤,結果保留兩位小數。

解題思路:

算出每類月餅的單價,按從大到小排序,每次選取單價最大的直到達到最大銷售量

注意:

月餅的庫存量以及最大銷售量一定要用浮點數儲存。雖然題目給的是整數,但是如果用整數儲存第三個測試點始終通不過。

完整程式碼:

#include<bits/stdc++.h>
using namespace std;

struct Mooncake{
	double amount;
	double price;
	double perpro;	
	
}mooncake[1001];

bool comp(Mooncake m1,Mooncake m2){
	return m1.perpro>m2.perpro;
}

int main(){
	int N,i;
	double profit=0.0,D;
	scanf("%d%lf",&N,&D);
	for(i=0;i<N;i++){
		scanf("%lf",&mooncake[i].amount);
	}
	for(i=0;i<N;i++){
		scanf("%lf",&mooncake[i].price);
		mooncake[i].perpro = float(mooncake[i].price)/mooncake[i].amount;			
	}
	sort(mooncake,mooncake+N,comp);
	for(i=0;i<N;i++){
		if(mooncake[i].amount <=D){
			profit+=mooncake[i].price;
			D-=mooncake[i].amount;
		}else{
			profit+=D*mooncake[i].perpro;
			break;
		}
	}
	printf("%.2f",profit);	
	return 0;
}