HDU 1061暴力打表找規律
阿新 • • 發佈:2018-12-24
Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 57447 Accepted Submission(s): 21742Problem Description
Given a positive integer N, you should output the most right digit of N^N.Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).Output
For each test case, you should output the rightmost digit of N^N.Sample Input
2
3
4Sample Output
7
6Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
思路
1、其實這個題目考察應該是快速冪取餘演算法,不過我並沒有用這個,我直接用暴力打表,找規律。感覺效率這個更高。
2、暴力打表方法這篇部落格我已經闡述—–暴力打表方法blog
程式碼
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
int main()
{
int t;
int a[20]={1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9,0};
cin>>t;
while (t--)
{
int n;
int sum;
cin>>n;
sum=(n-1)%20;
cout<<a[sum]<<endl;
}
return 0;
}