1. 程式人生 > >HDU 2899 二分答案

HDU 2899 二分答案

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6881    Accepted Submission(s): 4814


Problem Description Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input 2 100 200
Sample Output -74.4291 -178.8534
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <set>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <cctype>
#include <queue>
using namespace std;
typedef long long ll;
double x,y;
double val(double x)
{
    return 6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x-y*x;
}
double solve(double l,double r)
{
    double eps = 1e-7;
    while(l + eps < r)//確定一個終止查詢的條件
    {
        double lmid=l+(r-l)/3,rmid=r-(r-l)/3;
        if(val(lmid)<val(rmid))   r=rmid;
        else l=lmid;
    }
    return val(l);
}
int main()
{
    ll t;
    cin>>t;
    while(t--)
    {
        cin>>y;
        printf("%.4f\n", solve(0,100.0));
    }
}