1. 程式人生 > >pat(甲級)1004(dfs)

pat(甲級)1004(dfs)

1004 Counting Leaves (30)(30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level

 starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

思路:題意是輸出二叉樹的每一層葉節點的個數。

先用二維陣列儲存一個二維陣列的根節點和他們的子節點,然後dfs遍歷每一層,並記錄每層葉節點的數量。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
using namespace std;
int n,m,mx=-1;
vector <int> vc[120];
int vis[120];
void dfs(int x,int le)
{
	if(vc[x].size()==0)
	{
		vis[le]++;
		mx=max(mx,le);
		return ;
	}
	for(int i=0;i<vc[x].size();i++)
	{
		dfs(vc[x][i],le+1);
	}
}
int main(void)
{
	int i,j,k,zi,fu;
	scanf("%d %d",&n,&m);
	memset(vis,0,sizeof(vis));
	for(i=1;i<=m;i++)
	{
		scanf("%d %d",&fu,&k);
		for(j=1;j<=k;j++)
		{
			scanf("%d",&zi);
			vc[fu].push_back(zi);
		}
	}
	
	dfs(1,0);
	for(i=0;i<=mx;i++)
	{
		if(i==0) printf("%d",vis[i]);
		else printf(" %d",vis[i]);
	}
	return 0;
}