C++連線兩個字串
阿新 • • 發佈:2018-12-26
C++連線字串:
C++中只有字元型別,沒有字串型別,因此在C++中將兩個字串相連比較費事,在此我運用了
C++STL中的vector進行字串的連線。
題目:
Description
寫一函式,將兩個字串連線
Input
兩行字串
Output
連結後的字串
Sample Input
123
abc
Sample Output
123abc
程式碼:
#include <iostream>
#include <string>
#include <iomanip>
#include <cmath>
#include <algorithm>
#include <vector>
using namespace std;
vector<char> A;
void main() {
while (1) {
char c;
cin >> c;
if (c == 'S') {
break;
}
A.push_back(c);
}
for (auto b : A) {
cout << b;
}
}
當輸入字元123和abc輸入完畢時輸入S就可直接輸出結果,這裡運用了可變長度大小的容器vector,
方便輸入不受長度的限制。
執行結果: