1. 程式人生 > >Ancient Cipher 字串加密 重排

Ancient Cipher 字串加密 重排

Ancient Roman empire had a strong government system with various departments, including a secret
service department. Important documents were sent between provinces and the capital in encrypted
form to prevent eavesdropping. The most popular ciphers in those times were so called substitution
cipher
and permutation cipher.
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all
letters must be different. For some letters substitute letter may coincide with the original letter. For
example, applying substitution cipher that changes all letters from ‘A’ to ‘Y’ to the next ones in the
alphabet, and changes ‘Z’ to ‘A’, to the message “VICTORIOUS” one gets the message “WJDUPSJPVT”.
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation
2, 1, 5, 4, 3, 7, 6, 10, 9, 8to the message “VICTORIOUS” one gets the message
IVOTCIRSUO”.
It was quickly noticed that being applied separately, both substitution cipher and permutation
cipher were rather weak. But when being combined, they were strong enough for those times. Thus,
the most important messages were first encrypted using substitution cipher, and then the result was
encrypted using permutation cipher. Encrypting the message “VICTORIOUS” with the combination of
the ciphers described above one gets the message “JWPUDJSTVP”.
Archeologists have recently found the message engraved on a stone plate. At the first glance it
seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that
was encrypted, and now they want to check their conjecture. They need a computer program to do it,
so you have to write one.
Input

Input file contains several test cases. Each of them consists of two lines. The first line contains the
message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so
the encrypted message contains only capital letters of the English alphabet. The second line contains
the original message that is conjectured to be encrypted in the message on the first line. It also contains
only capital letters of the English alphabet.
The lengths of both lines of the input file are equal and do not exceed 100.
Output
For each test case, print one output line. Output ‘YES’ if the message on the first line of the input file
could be the result of encrypting the message on the second line, or ‘NO’ in the other case.
Sample Input
JWPUDJSTVP
VICTORIOUS
MAMA
ROME
HAHA
HEHE
AAA
AAA
NEERCISTHEBEST
SECRETMESSAGES
Sample Output
YES
NO
YES
YES

NO

題目大意:通過兩種方式加密一個字串:

1.將兩個字母表建立對映關係,如A->B,B->C...

2.按照某種排列將1得到的序列重排

由上面兩條規則,實際上還是建立一種對映關係,但是我們不容易確定這種對映,但是可以判斷出是否具有可行方案。

1.統計加密前的字串的26個字母出現的次數

2.統計加密後的字串的26個字母出現的次數

3.對統計得到的兩組資料排列並且比較

(1)如果相同,則是有可行方案

(2)如果不相同,則沒有可行方案

這個很好理解,對於同一個字母,如果加密前後出現的次數一樣,那麼他們就可以互相替代,如果每一個字母都滿足這種性質,就有解決方案。

#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
#define MAX 110
using namespace std;


bool judge(int *orgi,int *guess,int len)
{
    for(int i=0;i<len;i++)
    {
        if(orgi[i]!=guess[i])
            return false;
    }
    return true;
}
int main()
{
    char orig[MAX],guess[MAX];
    int orig_c[26],guess_c[26];
    int len,i;
    while(~scanf("%s",orig))
    {
        len=strlen(orig);
        memset(orig_c,0,sizeof(orig_c));
        memset(guess_c,0,sizeof(guess_c));
        scanf("%s",guess);
        for(i=0;i<len;i++)
        {
            orig_c[orig[i]-'A']++;
            guess_c[guess[i]-'A']++;
        }
        sort(orig_c,orig_c+26);
        sort(guess_c,guess_c+26);

        if(judge(orig_c,guess_c,26))
            printf("YES\n");
        else
            printf("NO\n");


    }
    return 0;
}