1. 程式人生 > >HDU1880-魔咒字典(暴力字串處理)

HDU1880-魔咒字典(暴力字串處理)

題目連結-HDU 1880

Problem Description

哈利波特在魔法學校的必修課之一就是學習魔咒。據說魔法世界有100000種不同的魔咒,哈利很難全部記住,但是為了對抗強敵,他必須在危急時刻能夠呼叫任何一個需要的魔咒,所以他需要你的幫助。

給你一部魔咒詞典。當哈利聽到一個魔咒時,你的程式必須告訴他那個魔咒的功能;當哈利需要某個功能但不知道該用什麼魔咒時,你的程式要替他找到相應的魔咒。如果他要的魔咒不在詞典中,就輸出“what?”

 

Input

首先列出詞典中不超過100000條不同的魔咒詞條,每條格式為:

[魔咒] 對應功能

其中“魔咒”和“對應功能”分別為長度不超過20和80的字串,字串中保證不包含字元“[”和“]”,且“]”和後面的字串之間有且僅有一個空格。詞典最後一行以“@

[email protected]”結束,這一行不屬於詞典中的詞條。
詞典之後的一行包含正整數N(<=1000),隨後是N個測試用例。每個測試用例佔一行,或者給出“[魔咒]”,或者給出“對應功能”。

 

Output

每個測試用例的輸出佔一行,輸出魔咒對應的功能,或者功能對應的魔咒。如果魔咒不在詞典中,就輸出“what?”

 

Sample Input

[expelliarmus] the disarming charm

[rictusempra] send a jet of silver light to hit the enemy

[tarantallegra] control the movement of one's legs

[serpensortia] shoot a snake out of the end of one's wand

[lumos] light the wand

[obliviate] the memory charm

[expecto patronum] send a Patronus to the dementors

[accio] the summoning charm

@[email protected]

4

[lumos]

the summoning charm

[arha]

take me to the sky

 

Sample Output

light the wand

accio

what?

what?

 

題目描述:

給你一個字典,讓你實現查詢的功能。

其實難點並不在於題意,主要是在於處理輸入輸出;輸入輸出我用的都是 gets()  ,它能吃空格,也能吃行首的回車,所以用這個吃進去,然後進行分離,然後再進行處理。

切記:存字串的陣列,一定要開夠大!我就是因為這個,錯了無數次....

程式碼篇:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

struct str{  //arr是單詞 brr是功能 crr是整體
    char arr[25],brr[85],crr[110];  //emmmm測試資料確實有滿串,所以這個陣列不能小
    int x;
} str[100005];

int main()
{
    char s[85];
    int n,m=1,i;
    while(gets(str[m].crr)){  //gest()輸入整行,然後進行分離
        if(str[m].crr[0] == '@')  //如果是@[email protected],跳出
            break;
        for( i=0; i<strlen(str[m].crr); i++){
            if(str[m].crr[i] == ']')
                break;
            str[m].arr[i] = str[m].crr[i];

        }
        str[m].arr[i]=']';

        i += 2;   //跳過中間的']' 和空格
        for(int a=i; a<strlen(str[m].crr); a++){
            str[m].brr[a-i] = str[m].crr[a];
        }
        m++;
    }

    scanf("%d ",&n);
    while(n--){
        gets(s);
        int flag=0;
        if(s[0]=='['){  //分開求,因為可能有一種情況,單詞和功能一樣,可能會混淆
            for( i=1; i<m; i++){
                if( strcmp( s , str[i].arr ) == 0){
                    printf("%s",str[i].brr);
                    flag = 1;
                    break;
                }
            }
        }
        else{
            for( i=1; i<m; i++){
                if( strcmp( s , str[i].brr ) == 0){
                    for(int j=1; j<strlen(str[i].arr)-1; j++) //不輸出'['和']'
                        printf("%c",str[i].arr[j]);
                    flag = 1;
                    break;
                }
            }
        }
        if( !flag ){
            printf("what?\n");
        }
        else
            printf("\n");
    }
    return 0;
}