1. 程式人生 > >Buy and Resell(貪心+思維+set)

Buy and Resell(貪心+思維+set)

Buy and Resell

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2048    Accepted Submission(s): 745


 

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

 

 

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.

 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

 

Sample Input

3 4 1 2 10 9 5 9 5 9 10 5 2 2 1

 

Sample Output

16 4 5 2 0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16

In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0

 

Source

2018中國大學生程式設計競賽 - 網路選拔賽

 

Recommend

chendu   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

題意:給出n個城市的物價,每個城市可以買也可以賣,求出在最大利潤的條件下最小的交易次數。

題解:用set維護前面的物價,當輸入一個x時,若大於set的首元素,則就在x這裡賣出set的首元素,同時將x加入set兩次,先加入一個交易代價為0的,再加入交易代價為1的,意思是可以反悔,一旦遇到比這個更大的便可以視作做這個x收回,在更大的這裡進行交易。

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<set>
#define rep(i,s,t) for(int i=s;i<=t;i++)
#define SI(i) scanf("%lld",&i)
#define PI(i) printf("%lld\n",i)
using namespace std;
typedef long long ll;
const int mod=1e9+7;
const int MAX=2e5+5;
const int INF=0x3f3f3f3f;
const double eps=1e-8;
int dir[9][2]={0,1,0,-1,1,0,-1,0, -1,-1,-1,1,1,-1,1,1};
template<class T>bool gmax(T &a,T b){return a<b?a=b,1:0;}
template<class T>bool gmin(T &a,T b){return a>b?a=b,1:0;}
template<class T>void gmod(T &a,T b){a=((a+b)%mod+mod)%mod;}
typedef pair<ll,ll> PII;

int a[MAX];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);

        multiset<PII>s;
        ll ans=0,cnt=0;
        for(int i=0;i<n;i++)
        {
            ll x;
            SI(x);

            if(!s.empty() && x>s.begin()->first)
            {
                ans+=x-s.begin()->first;
                cnt+=s.begin()->second*2;
                s.erase(s.begin());
                s.insert(make_pair(x,0));
                s.insert(make_pair(x,1));
            }
            else
            {
                s.insert(make_pair(x,1));
            }
        }

        printf("%lld %lld\n",ans,cnt);
    }
    return 0;
}