1. 程式人生 > >今夕何年(模擬日期)

今夕何年(模擬日期)

今夕何夕
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 568    Accepted Submission(s): 168
Problem Description
今天是2017年8月6日,農曆閏六月十五。 小度獨自憑欄,望著一輪圓月,發出了“今夕何夕,見此良人”的寂寞感慨。 為了排遣鬱結,它決定思考一個數學問題:接下來最近的哪一年裡的同一個日子,和今天的星期數一樣?比如今天是8月6日,星期日。下一個也是星期日的8月6日發生在2023年。 小貼士:在公曆中,能被4整除但不能被100整除,或能被400整除的年份即為閏年。
  Input
第一行為T,表示輸入資料組數。 每組資料包含一個日期,格式為YYYY-MM-DD。 1 ≤ T ≤ 10000 YYYY ≥ 2017 日期一定是個合法的日期 Output
對每組資料輸出答案年份,題目保證答案不會超過四位數。
  Sample Input
3
2017-08-06
2017-08-07
2018-01-01
  Sample Output
2023
2023
2024
#include <queue>
#include <map>
#include <vector>
#include <cmath>
#include <stack>
#include <climits>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;

int T[10003][13][35];
int yue[13] = {0,31,28,31,30,31,30,31,31,30,31,30,31};
int main()
{
    int num = 1;
    int year = 1,m = 1,n = 1;
    memset(T,-1,sizeof(T));
    while(!(year == 10000 && m == 1 && n == 1))
    {
        if(year%4==0 && year %100!=0 || year %400 == 0)
            yue[2] = 29;
        else
            yue[2] = 28;
        T[year][m][n] = num++;
        int j = n / yue[m];
        n++;
        if(j)
        {
            n = 1;
            j = (m) / 12;
            m++;
            if(j) m = 1;
            year += j;
        }
    }
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d-%d-%d",&year,&m,&n);
        int be = T[year][m][n];
        for(int i = year+1;i < 10000; i++)
        {
            if(T[i][m][n] != -1 && (T[i][m][n]-be) % 7 == 0)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}