1. 程式人生 > >poj2031Building a Space Station(幾何+最小生成樹)

poj2031Building a Space Station(幾何+最小生成樹)

Building a Space Station
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7361 Accepted: 3560

Description

You are a member of the space station engineering team, and are assigned(分配) a task in the construction process of the station. You are expected to write a computer program to complete the task. 
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined
(業已決定的)position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping(部分重疊). In an extreme(極端的)case, a cell may be totally enclosing(圍繞) another one. I do not know how such arrangements are possible. 

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted
(說明) transitively(及物的)

You are expected to design a configuration(配置), namely, which pairs of cells are to be connected with corridors(走廊). There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional
(比例的) to its length. Therefore, you should choose a plan with the shortest total length of the corridors. 

You can ignore(駁回訴訟) the width of a corridor(走廊). A corridor is built between points on two cells' surfaces. It can be made arbitrarily(武斷地) long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect(橫斷) in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

Input

The input(投入) consists of multiple data sets. Each data set is given in the following format. 

n
x1 y1 z1 r1
x2 y2 z2 r2
...
xn yn zn rn

The first line of a data set contains an integer(整數) n, which is the number of cells. n is positive(積極的), and does not exceed(超過) 100. 

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius(半徑) (called r in the rest of the problem) of the sphere(範圍), in this order. Each value is given by a decimal(小數的) fraction(分數), with 3 digits(數字) after the decimal point. Values are separated by a space character. 

Each of x, y, z and r is positive and is less than 100.0. 

The end of the input is indicated(表明) by a line containing a zero.

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

這道題也是一個求最短路的簡單問題

題意:在一個三位平面上有幾個球體,然後輸入資料是給你N個球的球心座標,以及半徑。科學家們想要實現各個球之間的接觸,也就是有表面的接觸。

            當然,兩個球之間可能會有相交的地方( dis(a,b) <= 0 ),那麼這兩個球是不用你新建道路來實現想通的,我們就可以把他們之間的距離設為0,然後再構建一個最小生成樹就好,求最短路也一樣,都可以解決~

同時這道題也發現了一點G++和C++的區別,算是一個細節吧。

資料位double型別的時候,用G++的時候scanf要用%lf,而printf的時候要用%f,否則會WA!

#include<stdio.h>
#include<math.h>
#include<string.h>
double map[110][110];
bool vis[110];
struct node
{
    double x,y,z,r;
}s[110];
double get(struct node a,struct node b)
{
    return sqrt( (a.x-b.x)*(a.x-b.x) + (a.y-b.y)*(a.y-b.y)  + (a.z-b.z)*(a.z-b.z) );
}
int main()
{
    int t;
    int n,m;
    int i,j;
    double x,y,z,r;
    double sum;
    while(~scanf("%d",&n)&&n)
    {
        sum = 0;
        for(i=1;i<=n;i++)
        {
            scanf("%lf%lf%lf%lf",&s[i].x,&s[i].y,&s[i].z,&s[i].r);
        }

        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
              if(i==j)
                map[i][j]=0;
            else map[i][j]=10000;

        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                double r = get(s[i],s[j])-(s[i].r+s[j].r);
                if(r<=0) map[i][j]=0;
                else map[i][j]=r;
            }
        }

        memset(vis,0,sizeof(vis));
        vis[1]=1;
        int u;
        for(i=1;i<n;i++)
        {
            double min = 10000;
            for(j=2;j<=n;j++)
            {
                if(!vis[j]&&min>map[1][j])
                {
                    min = map[1][j];
                    u=j;
                }
            }

            vis[u] = 1;
            sum+=min;

            for(j=2;j<=n;j++)
            {
                if(!vis[j]&&map[1][j]>map[u][j])
                    map[1][j] = map[u][j];
            }
        }
        printf("%.3lf\n",sum);

    }
    return 0;
}