1. 程式人生 > >HDoj-1789-Doing Homework again-不一樣的貪心

HDoj-1789-Doing Homework again-不一樣的貪心

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6900    Accepted Submission(s): 4109


Problem Description Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input 3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
Sample Output 0 3 5
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
struct  homework
{
	int deadline;
	int cost;
}work[1001];
bool cmp(homework a,homework b)
{
	if(a.cost!=b.cost)
	    return a.cost>b.cost;    // //科目按扣分從高到低排序,如果扣分相同,則科目期限短的考前
	else                         //按cost大小排序,若cost(學分)相同,截止時間短的放前面 
	    return a.deadline<b.deadline; 
	
}
int main()
{
	int s[1001];
	int i,j,k,m,n,T;
	scanf("%d",&T);
	while(T--)
	{
		memset(s,0,sizeof(s));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d",&work[i].deadline);
		}
		for(i=0;i<n;i++)
		{
			scanf("%d",&work[i].cost);
		}
		sort(work,work+n,cmp); //快排 
		int sum=0;
		for(i=0;i<n;i++)
		{
			j=work[i].deadline;  //交作業截止日期 
			while(j)             //判斷日期截止之前能做多少作業 
			{
				if(s[j]==0)     //如果今天沒有作業 
				{
					s[j]=1;     //標記為1 
					break;     
				}
				j--;             
			}
			if(j==0)         // 如果期限之內已經有作業了,那麼不得不扣分 
			{
				sum+=work[i].cost; 
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}