1. 程式人生 > >HDU5835 Danganronpa【水題】

HDU5835 Danganronpa【水題】

Danganronpa

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1613 Accepted Submission(s): 1010

Problem Description
Chisa Yukizome works as a teacher in the school. She prepares many gifts, which consist of n kinds with a[i] quantities of each kind, for her students and wants to hold a class meeting. Because of the busy work, she gives her gifts to the monitor, Chiaki Nanami. Due to the strange design of the school, the students' desks are in a row. Chiaki Nanami wants to arrange gifts like this:

  1. Each table will be prepared for a mysterious gift and an ordinary gift.

  2. In order to reflect the Chisa Yukizome's generosity, the kinds of the ordinary gift on the adjacent table must be different.

  3. There are no limits for the mysterious gift.

  4. The gift must be placed continuously.

She wants to know how many students can get gifts in accordance with her idea at most (Suppose the number of students are infinite). As the most important people of her, you are easy to solve it, aren't you?

Input
The first line of input contains an integer T(T≤10) indicating the number of test cases.

Each case contains one integer n. The next line contains n (1≤n≤10) numbers: a1,a2,...,an, (1≤ai≤100000).

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the answer of Chiaki Nanami's question.

Sample Input
1
2
3 2

Sample Output
Case #1: 2

Author
UESTC

Source
2016中國大學生程式設計競賽 - 網路選拔賽

問題連結HDU5835 Danganronpa
問題簡述
    n種禮物,已知每種禮物的數量,相鄰同學的禮物不能相同,問有多少個同學能拿到符合要求的禮物。
問題分析
    水題,不解釋。
程式說明:(略)
參考連結:(略)
題記:(略)

AC的C語言程式如下:

/* HDU5835 Danganronpa */

#include <stdio.h>

int main(void)
{
    int t, caseno = 0, n, sum, a, i;
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);

        sum = 0;
        for(i = 1; i <= n; i++) {
            scanf("%d", &a);
            sum += a;
        }

        printf("Case #%d: %d\n", ++caseno, sum / 2);
    }

    return 0;
}