1. 程式人生 > >ZOJ3210 A Stack or A Queue?【序列】

ZOJ3210 A Stack or A Queue?【序列】

Time Limit:1 Second     Memory Limit:32768 KB

Do you know stack and queue? They're both important data structures. A stack is a "first in last out" (FILO) data structure and a queue is a "first in first out" (FIFO) one.

Here comes the problem: given the order of some integers (it is assumed that the stack and queue are both for integers) going into the structure and coming out of it, please guess what kind of data structure it could be - stack or queue?

Notice that here we assume that none of the integers are popped out before all the integers are pushed into the structure.

Input

There are multiple test cases. The first line of input contains an integerT(T<= 100), indicating the number of test cases. ThenTtest cases follow.

Each test case contains 3 lines: The first line of each test case contains only one integerN

indicating the number of integers (1 <=N<= 100). The second line of each test case containsNintegers separated by a space, which are given in the order of going into the structure (that is, the first one is the earliest going in). The third line of each test case also containsNintegers separated by a space, whick are given in the order of coming out of the structure (the first one is the earliest coming out).

Output

For each test case, output your guess in a single line. If the structure can only be a stack, output "stack"; or if the structure can only be a queue, output "queue"; otherwise if the structure can be either a stack or a queue, output "both", or else otherwise output "neither".

Sample Input

4
3
1 2 3
3 2 1
3
1 2 3
1 2 3
3
1 2 1
1 2 1
3
1 2 3
2 3 1

Sample Output

stack
queue
both
neither
Author:CAO, Peng
Source:The 6th Zhejiang Provincial Collegiate Programming Contest

問題簡述

  根據輸入的資料,判定是堆疊還是佇列的問題。

問題分析

  讀入兩組資料分別放在2個數組中,做個迴圈處理就可以了,但是需要2個標誌。

程式說明:(略)

題記:(略)

參考連結:(略)

AC的C++語言程式如下:

/* A Stack or A Queue? */

#include <iostream>
#include <stdio.h>

using namespace std;

const int N = 100;
int a[N], b[N];

int main()
{
    int t, n;

    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
            scanf("%d", &a[i]);
        for(int i = 0; i < n; i++)
            scanf("%d", &b[i]);

        bool sflag = true, qflag = true;
        for(int i = 0; i < n; i++) {
            if(a[i] != b[n - i - 1])
                sflag = false;
            if(a[i] != b[i])
                qflag = false;
        }

        if(sflag && qflag)
            printf("both\n");
        else if(sflag)
            printf("stack\n");
        else if(qflag)
            printf("queue\n");
        else
            printf("neither\n");
    }

    return 0;
}